summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--kronolith-php72.patch12
-rw-r--r--php-horde-kronolith.spec22
2 files changed, 10 insertions, 24 deletions
diff --git a/kronolith-php72.patch b/kronolith-php72.patch
deleted file mode 100644
index fd51596..0000000
--- a/kronolith-php72.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -up ./lib/Event.php.fix ./lib/Event.php
---- ./lib/Event.php.fix 2017-10-13 14:30:50.754164418 +0200
-+++ ./lib/Event.php 2017-10-13 14:31:04.412234396 +0200
-@@ -795,7 +795,7 @@ abstract class Kronolith_Event
-
- // Tags
- if ($this->tags) {
-- if (count($this->tags == 1)) {
-+ if (count($this->tags) == 1) {
- $vEvent->setAttribute('CATEGORIES', $this->tags[0]);
- } else {
- $vEvent->setAttribute('CATEGORIES', '', array(), true, $this->tags);
diff --git a/php-horde-kronolith.spec b/php-horde-kronolith.spec
index c7dffe7..accb5ad 100644
--- a/php-horde-kronolith.spec
+++ b/php-horde-kronolith.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-horde-kronolith
#
-# Copyright (c) 2012-2017 Remi Collet
+# Copyright (c) 2012-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -11,20 +11,14 @@
%global pear_channel pear.horde.org
Name: php-horde-kronolith
-Version: 4.2.23
-Release: 2%{?dist}
+Version: 4.2.24
+Release: 1%{?dist}
Summary: A web based calendar
-Group: Development/Libraries
License: GPLv2
URL: http://www.horde.org/apps/kronolith
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-# See comments on:
-# https://github.com/horde/kronolith/commit/9bfed34dc259824ddf1c3cd52fb6442f7f29d42b
-# https://github.com/horde/kronolith/commit/d996704daca092d92144f10d9f3d12e04f2b9dcb
-Patch0: %{pear_name}-php72.patch
-
BuildArch: noarch
BuildRequires: gettext
BuildRequires: php(language) >= 5.3.0
@@ -162,7 +156,6 @@ cat <<EOF | tee httpd.conf
EOF
cd %{pear_name}-%{version}
-%patch0 -p1 -b .php72
# Don't install .po and .pot files
# Remove checksum for .mo, as we regenerate them
@@ -216,9 +209,11 @@ done | tee ../%{pear_name}.lang
cd %{pear_name}-%{version}/test/Kronolith
ret=0
-for cmd in php php56 php70 php71 php72; do
+for cmd in php php70 php71 php72 php73; do
if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose . || ret=1
+ $cmd %{_bindir}/phpunit --bootstrap bootstrap.php \
+ --filter '^((?!(testBasicVersion1)).)*$' \
+ --verbose . || ret=1
fi
done
exit $ret
@@ -266,6 +261,9 @@ fi
%changelog
+* Thu Jul 5 2018 Remi Collet <remi@remirepo.net> - 4.2.24-1
+- update to 4.2.24
+
* Fri Oct 13 2017 Remi Collet <remi@remirepo.net> - 4.2.23-2
- add temporary patch for PHP 7.2, FTBFS from Koschei