summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-04-23 10:10:24 +0200
committerRemi Collet <remi@remirepo.net>2019-04-23 10:10:24 +0200
commit2ca7950ca71eefe38405c74e7a7a0c7214815bae (patch)
tree132a1b95193292af9d0600f0a6175a18bc74ac66
parent8ddd7eadc66cdb1b63e7bd0545a9e31fd51251c2 (diff)
- update to 5.2.21HEADmaster
- use range dependencies
-rw-r--r--php-horde-horde.spec52
1 files changed, 50 insertions, 2 deletions
diff --git a/php-horde-horde.spec b/php-horde-horde.spec
index 0738cfb..8df3ea4 100644
--- a/php-horde-horde.spec
+++ b/php-horde-horde.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-horde-horde
#
-# Copyright (c) 2012-2018 Remi Collet
+# Copyright (c) 2012-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -13,7 +13,7 @@
%global with_sysjs 0
Name: php-horde-horde
-Version: 5.2.20
+Version: 5.2.21
Release: 1%{?dist}
Summary: Horde Application Framework
@@ -55,6 +55,49 @@ Requires: php-hash
Requires: php-pear(PEAR) >= 1.7.0
Requires: php-channel(%{pear_channel})
Requires: php-pear(%{pear_channel}/Horde_Role) >= 1.0.0
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-pear(%{pear_channel}/Horde_Alarm) >= 2.1.0 with php-pear(%{pear_channel}/Horde_Alarm) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Argv) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Argv) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Auth) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Auth) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Autoloader) >= 2.1.0 with php-pear(%{pear_channel}/Horde_Autoloader) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Browser) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Browser) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Core) >= 2.12.0 with php-pear(%{pear_channel}/Horde_Core) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Date) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Date) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Exception) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Form) >= 2.0.16 with php-pear(%{pear_channel}/Horde_Form) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Group) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Group) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Http) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Http) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Image) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Image) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_LoginTasks) >= 2.0.0 with php-pear(%{pear_channel}/Horde_LoginTasks) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Mail) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Mail) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Mime) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Mime) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Nls) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Nls) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Perms) >= 2.1.5 with php-pear(%{pear_channel}/Horde_Perms) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Prefs) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Prefs) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Rpc) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Rpc) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Serialize) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Serialize) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Support) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Support) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Text_Diff) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Text_Diff) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Token) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Token) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Text_Filter) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Text_Filter) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Tree) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Tree) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Url) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Url) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Util) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Util) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_View) >= 2.0.0 with php-pear(%{pear_channel}/Horde_View) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Vfs) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Vfs) < 3)
+# Optional
+Recommends: php-pear(File_Find)
+Recommends: php-pear(File_Fstab)
+Recommends: php-pear(Console_Getopt)
+Recommends: php-pear(Console_Table)
+Recommends: php-pear(Net_DNS2)
+Recommends: (php-pear(%{pear_channel}/Horde_Db) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Db) < 3)
+Recommends: (php-pear(%{pear_channel}/Horde_Feed) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Feed) < 3)
+Recommends: (php-pear(%{pear_channel}/Horde_Oauth) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Oauth) < 3)
+Recommends: (php-pear(%{pear_channel}/Horde_OpenXchange) >= 1.0.0 with php-pear(%{pear_channel}/Horde_OpenXchange) < 2)
+Recommends: (php-pear(%{pear_channel}/Horde_Service_Weather) >= 2.2.0 with php-pear(%{pear_channel}/Horde_Service_Weather) < 3)
+Recommends: (php-pear(%{pear_channel}/Horde_SyncMl) >= 2.0.0 with php-pear(%{pear_channel}/Horde_SyncMl) < 3)
+%else
Requires: php-pear(%{pear_channel}/Horde_Alarm) >= 2.1.0
Requires: php-pear(%{pear_channel}/Horde_Alarm) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Argv) >= 2.0.0
@@ -127,6 +170,7 @@ Requires: php-pear(%{pear_channel}/Horde_Service_Weather) >= 2.2.0
Requires: php-pear(%{pear_channel}/Horde_Service_Weather) < 3.0.0
# Optional but implicitly required
# Horde_Db, Horde_Oauth, Horde_SyncMl
+%endif
# Optional but TODO
# Horde_Service_Facebook
# Horde_Service_Twitter
@@ -291,6 +335,10 @@ fi
%changelog
+* Tue Apr 23 2019 Remi Collet <remi@remirepo.net> - 5.2.21-1
+- update to 5.2.21
+- use range dependencies
+
* Thu Sep 27 2018 Remi Collet <remi@remirepo.net> - 5.2.20-1
- update to 5.2.20