summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-09-15 19:19:19 +0200
committerRemi Collet <fedora@famillecollet.com>2014-09-15 19:19:19 +0200
commit244f02da09fd86fdcea2f0e1ca42a54ed2936c13 (patch)
tree1e625c42fde002e96ad43f6db6ca2834a51bcf32
php-horde-horde-lz4: 1.0.6 - New package
-rw-r--r--Makefile4
-rw-r--r--REFLECTION19
-rw-r--r--horde_lz4-systemlib.patch55
-rw-r--r--php-horde-horde-lz4-dev.spec221
-rw-r--r--php-horde-horde-lz4.spec196
5 files changed, 495 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..1ad557a
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,19 @@
+Extension [ <persistent> extension #92 horde_lz4 version 1.0.6 ] {
+
+ - Functions {
+ Function [ <internal:horde_lz4> function horde_lz4_compress ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $high ]
+ }
+ }
+ Function [ <internal:horde_lz4> function horde_lz4_uncompress ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $data ]
+ }
+ }
+ }
+}
+
diff --git a/horde_lz4-systemlib.patch b/horde_lz4-systemlib.patch
new file mode 100644
index 0000000..4dbb165
--- /dev/null
+++ b/horde_lz4-systemlib.patch
@@ -0,0 +1,55 @@
+diff -up ./config.m4.old ./config.m4
+--- ./config.m4.old 2014-09-15 17:01:16.231167165 +0200
++++ ./config.m4 2014-09-15 18:09:13.730717415 +0200
+@@ -24,9 +24,38 @@ fi
+ PHP_ARG_ENABLE(horde_lz4, whether to enable horde_lz4 support,
+ [ --enable-horde_lz4 Enable horde_lz4 support])
+
++PHP_ARG_WITH(liblz4, whether to use system liblz4,
++[ --with-liblz4 Use system liblz4], no, no)
++
+ if test "$PHP_HORDE_LZ4" != "no"; then
+
+- PHP_NEW_EXTENSION(horde_lz4, horde_lz4.c lz4.c lz4hc.c, $ext_shared)
++ sources=horde_lz4.c
++
++ if test "$PHP_LIBLZ4" != "no"; then
++ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
++ AC_MSG_CHECKING(liblz4 version)
++ if test -x "$PKG_CONFIG" && $PKG_CONFIG --exists liblz4; then
++ LIBLZ4_INCLUDE=`$PKG_CONFIG liblz4 --cflags`
++ LIBLZ4_LIBRARY=`$PKG_CONFIG liblz4 --libs`
++ LIBLZ4_VERSION=`$PKG_CONFIG liblz4 --modversion`
++ fi
++
++ if test -z "$LIBLZ4_VERSION"; then
++ AC_MSG_RESULT(liblz4.pc not found)
++ AC_CHECK_HEADERS([lz4.h])
++ PHP_CHECK_LIBRARY(lz4, LZ4_decompress_fast,
++ [PHP_ADD_LIBRARY(lz4, 1, HORDE_LZ4_SHARED_LIBADD)],
++ [AC_MSG_ERROR(lz4 library not found)])
++ else
++ AC_MSG_RESULT($LIBLZ4_VERSION)
++ PHP_EVAL_INCLINE($LIBLZ4_INCLUDE)
++ PHP_EVAL_LIBLINE($LIBLZ4_LIBRARY, HORDE_LZ4_SHARED_LIBADD)
++ fi
++ else
++ sources="$sources lz4.c lz4hc.c"
++ fi
++ PHP_NEW_EXTENSION(horde_lz4, $sources, $ext_shared)
++ PHP_SUBST(HORDE_LZ4_SHARED_LIBADD)
+
+ ifdef([PHP_INSTALL_HEADERS],
+ [
+diff -up ./horde_lz4.c.old ./horde_lz4.c
+--- ./horde_lz4.c.old 2014-09-15 17:24:33.521673922 +0200
++++ ./horde_lz4.c 2014-09-15 17:25:24.225908322 +0200
+@@ -150,7 +150,7 @@ PHP_FUNCTION(horde_lz4_uncompress)
+ RETURN_FALSE;
+ }
+
+- output_len = LZ4_uncompress(p + header_offset, output, data_len);
++ output_len = LZ4_decompress_fast(p + header_offset, output, data_len);
+
+ if (output_len <= 0) {
+ RETVAL_FALSE;
diff --git a/php-horde-horde-lz4-dev.spec b/php-horde-horde-lz4-dev.spec
new file mode 100644
index 0000000..c991866
--- /dev/null
+++ b/php-horde-horde-lz4-dev.spec
@@ -0,0 +1,221 @@
+# spec file for php-horde-horde-lz4
+#
+# Copyright (c) 2014 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{?scl: %scl_package php-horde-horde-lz4}
+%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
+%{!?__pecl: %global __pecl %{_bindir}/pecl}
+%{!?__php: %global __php %{_bindir}/php}
+
+%global with_zts 0%{?__ztsphp:1}
+%global pecl_name horde_lz4
+%global pecl_channel pear.horde.org
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
+%if 0%{?scl:1}
+# PHPUnit not available in SCL
+%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%else
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%endif
+
+Summary: Horde LZ4 Compression Extension
+Name: %{?scl_prefix}php-horde-horde-lz4
+Version: 1.0.6
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: MIT
+Group: Development/Languages
+URL: http://www.horde.org
+Source0: http://%{pecl_channel}/get/%{pecl_name}-%{version}.tgz
+
+Patch0: %{pecl_name}-systemlib.patch
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: %{?scl_prefix}php-channel(%{pecl_channel})
+BuildRequires: lz4-devel
+%if %{with_tests}
+BuildRequires: %{_bindir}/phpunit
+%endif
+
+Requires(post): %{__pecl}
+Requires(postun): %{__pecl}
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+Requires: %{?scl_prefix}php-channel(%{pecl_channel})
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_channel}/%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_channel}/%{pecl_name})%{?_isa} = %{version}
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
+# Other third party repo stuff
+Obsoletes: php53-pecl-%{pecl_name} <= %{version}
+Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "5.5"
+Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+PHP extension that implements the LZ4 compression algorithm,
+an extremely fast lossless compression algorithm.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection}.
+
+
+%prep
+%setup -q -c
+mv %{pecl_name}-%{version} NTS
+
+cd NTS
+# Use system library
+%patch0 -p0 -b .systemlib
+rm lz4.? lz4hc.?
+sed -e '/LICENSE.lz4/d' -i ../package.xml
+
+# Fix the version
+sed -e '/HORDE_LZ4_EXT_VERSION/s/1.0.4/%{version}/' -i horde_lz4.h
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define HORDE_LZ4_EXT_VERSION/{s/.* "//;s/".*$//;p}' horde_lz4.h)
+if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat << 'EOF' | tee %{ini_name}
+; Enable %{summary} module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-liblz4 \
+ --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-liblz4 \
+ --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+
+make -C NTS install-modules INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install-modules INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pear_docdir}/%{pecl_name}/$i
+done
+
+
+%post
+%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{pecl_uninstall} %{pecl_channel}/%{pecl_name} >/dev/null || :
+fi
+
+
+%check
+cd NTS
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=modules/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_tests}
+: Upstream test suite for NTS extension
+%{__php} -d extension=modules/horde_lz4.so %{_bindir}/phpunit test
+%endif
+
+%if %{with_zts}
+cd ../ZTS
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=modules/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_tests}
+: Upstream test suite for ZTS extension
+%{__ztsphp} -d extension=modules/horde_lz4.so %{_bindir}/phpunit test
+%endif
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Mon Sep 15 2014 Remi Collet <remi@fedoraproject.org> - 1.0.6-1
+- initial package, version 1.0.6 \ No newline at end of file
diff --git a/php-horde-horde-lz4.spec b/php-horde-horde-lz4.spec
new file mode 100644
index 0000000..2f1c3d1
--- /dev/null
+++ b/php-horde-horde-lz4.spec
@@ -0,0 +1,196 @@
+# spec file for php-horde-horde-lz4
+#
+# Copyright (c) 2014 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
+%{!?__pecl: %global __pecl %{_bindir}/pecl}
+%{!?__php: %global __php %{_bindir}/php}
+
+%global with_zts 0%{?__ztsphp:1}
+%global pecl_name horde_lz4
+%global pecl_channel pear.horde.org
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+
+Summary: Horde LZ4 Compression Extension
+Name: php-horde-horde-lz4
+Version: 1.0.6
+Release: 1%{?dist}
+License: MIT
+Group: Development/Languages
+URL: http://www.horde.org
+Source0: http://%{pecl_channel}/get/%{pecl_name}-%{version}.tgz
+
+Patch0: %{pecl_name}-systemlib.patch
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: php-devel
+BuildRequires: php-pear
+BuildRequires: php-channel(%{pecl_channel})
+BuildRequires: lz4-devel
+%if %{with_tests}
+BuildRequires: %{_bindir}/phpunit
+%endif
+
+Requires(post): %{__pecl}
+Requires(postun): %{__pecl}
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
+Requires: php-channel(%{pecl_channel})
+
+Provides: php-%{pecl_name} = %{version}
+Provides: php-%{pecl_name}%{?_isa} = %{version}
+Provides: php-pecl(%{pecl_channel}/%{pecl_name}) = %{version}
+Provides: php-pecl(%{pecl_channel}/%{pecl_name})%{?_isa} = %{version}
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+PHP extension that implements the LZ4 compression algorithm,
+an extremely fast lossless compression algorithm.
+
+
+%prep
+%setup -q -c
+mv %{pecl_name}-%{version} NTS
+
+cd NTS
+# Use system library
+%patch0 -p0 -b .systemlib
+rm lz4.? lz4hc.?
+sed -e '/LICENSE.lz4/d' -i ../package.xml
+
+# Fix the version
+sed -e '/HORDE_LZ4_EXT_VERSION/s/1.0.4/%{version}/' -i horde_lz4.h
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define HORDE_LZ4_EXT_VERSION/{s/.* "//;s/".*$//;p}' horde_lz4.h)
+if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat << 'EOF' | tee %{ini_name}
+; Enable %{summary} module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-liblz4 \
+ --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-liblz4 \
+ --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+
+make -C NTS install-modules INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install-modules INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pear_docdir}/%{pecl_name}/$i
+done
+
+
+%post
+%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{pecl_uninstall} %{pecl_channel}/%{pecl_name} >/dev/null || :
+fi
+
+
+%check
+cd NTS
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=modules/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_tests}
+: Upstream test suite for NTS extension
+%{__php} -d extension=modules/horde_lz4.so %{_bindir}/phpunit test
+%endif
+
+%if %{with_zts}
+cd ../ZTS
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=modules/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_tests}
+: Upstream test suite for ZTS extension
+%{__ztsphp} -d extension=modules/horde_lz4.so %{_bindir}/phpunit test
+%endif
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Mon Sep 15 2014 Remi Collet <remi@fedoraproject.org> - 1.0.6-1
+- initial package, version 1.0.6 \ No newline at end of file