summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore8
-rw-r--r--php-horde-content.spec18
2 files changed, 21 insertions, 5 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-horde-content.spec b/php-horde-content.spec
index e8867d4..3be9e42 100644
--- a/php-horde-content.spec
+++ b/php-horde-content.spec
@@ -12,7 +12,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-horde-content
-Version: 2.0.5
+Version: 2.0.6
Release: 1%{?dist}
Summary: Tagging application
@@ -21,7 +21,6 @@ License: BSD
URL: http://%{pear_channel}
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php(language) >= 5.3.0
BuildRequires: php-pear(PEAR) >= 1.7.0
@@ -79,8 +78,15 @@ cd %{pear_name}-%{version}
(
echo "<Directory %{pear_hordedir}/%{pear_name}>"
cat .htaccess
+echo -e "</Directory>\n"
+echo "<Directory %{pear_hordedir}/%{pear_name}/config>"
+echo " Deny from all"
+echo -e "</Directory>\n"
+echo "<Directory %{pear_hordedir}/%{pear_name}/lib>"
+echo " Deny from all"
echo "</Directory>"
-) | tee ../httpd.conf
+) > ../httpd.conf
+cat ../httpd.conf
# Remove htaccess as we provide httpd.conf
sed -e '/htaccess/d' \
@@ -136,13 +142,12 @@ fi
%files
-%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%config(noreplace) %{_sysconfdir}/httpd/conf.d/%{name}.conf
%attr(0770,apache,apache) %dir %{_sysconfdir}/horde/%{pear_name}
%attr(0660,apache,apache) %config(noreplace) %{_sysconfdir}/horde/%{pear_name}/*.php
-%{pear_testdir}/%{pear_name}
+%doc %{pear_testdir}/%{pear_name}
%{_bindir}/content-object-add
%{_bindir}/content-object-delete
%{_bindir}/content-tag
@@ -157,6 +162,9 @@ fi
%changelog
+* Tue Sep 19 2017 Remi Collet <remi@remirepo.net> - 2.0.6-1
+- Update to 2.0.6 (no change)
+
* Wed Oct 21 2015 Remi Collet <remi@fedoraproject.org> - 2.0.5-1
- Update to 2.0.5
- add provides php-composer(horde/content)