summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-06-08 09:49:19 +0200
committerRemi Collet <fedora@famillecollet.com>2014-06-08 09:49:19 +0200
commit4855a5696065d0fdde63789185cbbd3ad4df5e50 (patch)
tree8b3c6495a5871274ffae04f861b2410097bf9ef5
parentff27146ab30b4026dbe3304a0a791cae7fdd9c7e (diff)
horde: fix FTBFS (include path) + cleanups
-rw-r--r--php-horde-Horde-Xml-Wbxml.spec19
1 files changed, 14 insertions, 5 deletions
diff --git a/php-horde-Horde-Xml-Wbxml.spec b/php-horde-Horde-Xml-Wbxml.spec
index 3a9c243..b3a9ab5 100644
--- a/php-horde-Horde-Xml-Wbxml.spec
+++ b/php-horde-Horde-Xml-Wbxml.spec
@@ -1,5 +1,13 @@
-%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
-%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+# spec file for php-horde-Horde-Xml-Wbxml
+#
+# Copyright (c) 2012-2014 Nick Bebout, Remi Collet
+#
+# License: MIT
+# https://fedoraproject.org/wiki/Licensing:MIT#Modern_Style_with_sublicense
+#
+# Please, preserve the changelog entries
+#
+%{!?__pear: %global __pear %{_bindir}/pear}
%global pear_name Horde_Xml_Wbxml
%global pear_channel pear.horde.org
@@ -32,7 +40,7 @@ Requires: php-pcre
Requires: php-xml
Requires: php-channel(%{pear_channel})
Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
-Conflicts: php-pear(%{pear_channel}/Horde_Util) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) < 3.0.0
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
@@ -68,9 +76,10 @@ install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
+src=$(pwd)/%{pear_name}-%{version}
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-phpunit\
- -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
+phpunit \
+ --include-path=$src/lib \
-d date.timezone=UTC \
.