summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-02-10 10:07:49 +0100
committerRemi Collet <fedora@famillecollet.com>2013-02-10 10:07:49 +0100
commit4fedd12c19fa3efefd3ef193b5502275b83e841a (patch)
treea91ec6124b2ec84dd9625a9e2ca6ddef3d5700e8
parent97f66ddc598a6f29402dc5718e511667211c3203 (diff)
php-horde-Horde-View: cleanups for review
-rw-r--r--php-horde-Horde-View.spec35
1 files changed, 22 insertions, 13 deletions
diff --git a/php-horde-Horde-View.spec b/php-horde-Horde-View.spec
index aa1cbef..eabc31b 100644
--- a/php-horde-Horde-View.spec
+++ b/php-horde-Horde-View.spec
@@ -5,16 +5,17 @@
Name: php-horde-Horde-View
Version: 2.0.1
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Horde View API
Group: Development/Libraries
-License: LGPLv2+
-URL: http://pear.horde.org
+License: LGPLv2
+URL: http://%{pear_channel}
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
+BuildRequires: php-common >= 5.3.0
BuildRequires: php-pear(PEAR) >= 1.7.0
BuildRequires: php-channel(%{pear_channel})
# To run unit tests
@@ -23,8 +24,13 @@ BuildRequires: php-pear(%{pear_channel}/Horde_Controller) >= 2.0.0
Requires(post): %{__pear}
Requires(postun): %{__pear}
+Requires: php-common >= 5.3.0
+Requires: php-date
+Requires: php-json
+Requires: php-pcre
+Requires: php-reflection
+Requires: php-spl
Requires: php-pear(PEAR) >= 1.7.0
-Requires: php(language) >= 5.3.0
Requires: php-channel(%{pear_channel})
Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
@@ -46,8 +52,7 @@ A simple View pattern implementation.
%prep
-%setup -q -c -T
-tar xif %{SOURCE0}
+%setup -q -c
cd %{pear_name}-%{version}
cp ../package.xml %{name}.xml
@@ -71,10 +76,11 @@ install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
+# Ignore test results for now ( > vs /> ) need investigation
+src=$(pwd)/%{pear_name}-%{version}
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-# Ignore test results for now ( > vs /> )
-phpunit\
- -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
+phpunit \
+ -d include_path=$src/lib:.:%{pear_phpdir} \
-d date.timezone=UTC \
. || exit 0
@@ -100,11 +106,14 @@ fi
%changelog
-* Mon Nov 19 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.1-1
-- Update to 2.0.1 for remi repo
+* Sun Feb 10 2013 Remi Collet <remi@fedoraproject.org> - 2.0.1-2
+- cleanups for review
-* Fri Nov 2 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.0-1
-- Update to 2.0.0 for remi repo
+* Mon Nov 19 2012 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
+- Update to 2.0.1
+
+* Fri Nov 2 2012 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
+- Update to 2.0.0
* Sat Jan 28 2012 Nick Bebout <nb@fedoraproject.org> - 1.0.1-1
- Initial package