summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Vfs.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-03 08:17:37 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-03 08:17:37 +0100
commit47914f44783ec027dea6c25fe51f831b0cb3b64f (patch)
tree1629bc92f2bc525be2bb98224dbdbc35b7880ad8 /php-horde-Horde-Vfs.spec
parentfac6481a3b0b7bc5990b34385ca23829850ebcc9 (diff)
php-horde-Horde-Vfs: 2.0.0
Diffstat (limited to 'php-horde-Horde-Vfs.spec')
-rw-r--r--php-horde-Horde-Vfs.spec106
1 files changed, 78 insertions, 28 deletions
diff --git a/php-horde-Horde-Vfs.spec b/php-horde-Horde-Vfs.spec
index cf16320..545a797 100644
--- a/php-horde-Horde-Vfs.spec
+++ b/php-horde-Horde-Vfs.spec
@@ -1,27 +1,45 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
-%global pear_name Horde_Vfs
+%global pear_name Horde_Vfs
+%global pear_channel pear.horde.org
Name: php-horde-Horde-Vfs
-Version: 1.0.9
+Version: 2.0.0
Release: 1%{?dist}
Summary: Virtual File System API
Group: Development/Libraries
License: LGPLv2+
URL: http://pear.horde.org
-Source0: http://pear.horde.org/get/%{pear_name}-%{version}.tgz
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+# /usr/lib/rpm/find-lang.sh from fedora 16
+Source1: find-lang.sh
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
-BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-pear
+BuildRequires: php-channel(%{pear_channel})
+BuildRequires: gettext
+# To run unit tests
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Db) >= 2.0.0
+
Requires(post): %{__pear}
Requires(postun): %{__pear}
-Provides: php-pear(pear.horde.org/%{pear_name}) = %{version}
-Requires: php-pear(pear.horde.org/Horde_Exception) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Translation) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Util) < 2.0.0
-Requires: php-pear(PEAR) >= 1.7.0
-BuildRequires: php-channel(pear.horde.org)
-Requires: php-channel(pear.horde.org)
+Requires: php(language) >= 5.3.0
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Translation) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Translation) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Util) >= 3.0.0
+# Optionnal
+Requires: php-pear(%{pear_channel}/Horde_Db) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Db) >= 3.0.0
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
%description
This package provides a Virtual File System API, with backends for:
@@ -37,33 +55,55 @@ This package provides a Virtual File System API, with backends for:
Reading, writing and listing of files are all supported, and there are both
object-based and array-based interfaces to directory listings.
-%prep
-%setup -q -c
-[ -f package2.xml ] || mv package.xml package2.xml
-mv package2.xml %{pear_name}-%{version}/%{name}.xml
-# Create a "localized" php.ini to avoid build warning
-cp /etc/php.ini .
-echo "date.timezone=UTC" >>php.ini
+%prep
+%setup -q -c -T
+tar xif %{SOURCE0}
cd %{pear_name}-%{version}
+# Don't install .po and .pot files
+# Remove checksum for .mo, as we regenerate them
+sed -e '/%{pear_name}.po/d' \
+ -e '/Horde_Other.po/d' \
+ -e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \
+ ../package.xml >%{name}.xml
+
%build
cd %{pear_name}-%{version}
-# Empty build section, most likely nothing required.
+
+# Regenerate the locales
+for po in $(find locale -name \*.po)
+do
+ msgfmt $po -o $(dirname $po)/$(basename $po .po).mo
+done
%install
cd %{pear_name}-%{version}
-PHPRC=../php.ini %{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+%if 0%{?fedora} > 13
+%find_lang %{pear_name}
+%else
+sh %{SOURCE1} %{buildroot} %{pear_name}
+%endif
+
+
+%check
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+# Need investigation
+rm -f FileTest.php
+phpunit -d date.timezone=UTC AllTests.php
+
%post
%{__pear} install --nodeps --soft --force --register-only \
@@ -72,19 +112,29 @@ install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
%postun
if [ $1 -eq 0 ] ; then
%{__pear} uninstall --nodeps --ignore-errors --register-only \
- pear.horde.org/%{pear_name} >/dev/null || :
+ %{pear_channel}/%{pear_name} >/dev/null || :
fi
-%files
+%files -f %{pear_name}-%{version}/%{pear_name}.lang
+%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
+%{_bindir}/horde-vfs
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/Vfs
%{pear_phpdir}/Horde/Vfs.php
-%{pear_datadir}/Horde_Vfs
-%{pear_testdir}/Horde_Vfs
-%{_bindir}/horde-vfs
+%{pear_testdir}/%{pear_name}
+# own locales (non standard) directories, .mo own by find_lang
+%dir %{pear_datadir}/%{pear_name}
+%dir %{pear_datadir}/%{pear_name}/locale
+%dir %{pear_datadir}/%{pear_name}/locale/*
+%dir %{pear_datadir}/%{pear_name}/locale/*/LC_MESSAGES
+%{pear_datadir}/%{pear_name}/migration
+
%changelog
+* Sat Nov 3 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.0-1
+- Update to 2.0.0 for remi repo
+
* Thu Jun 21 2012 Nick Bebout <nb@fedoraproject.org> - 1.0.9-1
- Upgrade to 1.0.9