summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-02 07:13:03 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-02 07:13:03 +0100
commitfac6481a3b0b7bc5990b34385ca23829850ebcc9 (patch)
tree7496d51b6e19646f64052c6facd1e188a36ff1d6
php-horde-Horde-Vfs: import from review
-rw-r--r--php-horde-Horde-Vfs.spec92
1 files changed, 92 insertions, 0 deletions
diff --git a/php-horde-Horde-Vfs.spec b/php-horde-Horde-Vfs.spec
new file mode 100644
index 0000000..cf16320
--- /dev/null
+++ b/php-horde-Horde-Vfs.spec
@@ -0,0 +1,92 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Horde_Vfs
+
+Name: php-horde-Horde-Vfs
+Version: 1.0.9
+Release: 1%{?dist}
+Summary: Virtual File System API
+
+Group: Development/Libraries
+License: LGPLv2+
+URL: http://pear.horde.org
+Source0: http://pear.horde.org/get/%{pear_name}-%{version}.tgz
+
+BuildArch: noarch
+BuildRequires: php-pear(PEAR) >= 1.7.0
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Provides: php-pear(pear.horde.org/%{pear_name}) = %{version}
+Requires: php-pear(pear.horde.org/Horde_Exception) < 2.0.0
+Requires: php-pear(pear.horde.org/Horde_Translation) < 2.0.0
+Requires: php-pear(pear.horde.org/Horde_Util) < 2.0.0
+Requires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-channel(pear.horde.org)
+Requires: php-channel(pear.horde.org)
+
+%description
+This package provides a Virtual File System API, with backends for:
+
+* SQL
+* FTP
+* Local filesystems
+* Hybrid SQL and filesystem
+* Samba
+* SSH2/SFTP
+* IMAP (Kolab)
+
+Reading, writing and listing of files are all supported, and there are both
+object-based and array-based interfaces to directory listings.
+
+%prep
+%setup -q -c
+[ -f package2.xml ] || mv package.xml package2.xml
+mv package2.xml %{pear_name}-%{version}/%{name}.xml
+
+# Create a "localized" php.ini to avoid build warning
+cp /etc/php.ini .
+echo "date.timezone=UTC" >>php.ini
+
+cd %{pear_name}-%{version}
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+PHPRC=../php.ini %{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+
+# Clean up unnecessary files
+rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+
+# Install XML package description
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ pear.horde.org/%{pear_name} >/dev/null || :
+fi
+
+%files
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/Vfs
+%{pear_phpdir}/Horde/Vfs.php
+%{pear_datadir}/Horde_Vfs
+%{pear_testdir}/Horde_Vfs
+%{_bindir}/horde-vfs
+
+%changelog
+* Thu Jun 21 2012 Nick Bebout <nb@fedoraproject.org> - 1.0.9-1
+- Upgrade to 1.0.9
+
+* Sat Jan 28 2012 Nick Bebout <nb@fedoraproject.org> - 1.0.8-1
+- Initial package