summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-14 09:36:39 +0200
committerRemi Collet <remi@remirepo.net>2020-10-14 09:36:39 +0200
commit60266c5036290c5ecd05abb2eff939f978208ce2 (patch)
tree4a0d1c89658ce9cb35e3321c87281e6ede7ea9be
parentb91df65c7fc93cd4b7a8305687d34c4001f55df7 (diff)
update to 2.4.1HEADmaster
use weak and range dependencies
-rw-r--r--.gitignore9
-rw-r--r--php-horde-Horde-Vfs.spec84
2 files changed, 55 insertions, 38 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-horde-Horde-Vfs.spec b/php-horde-Horde-Vfs.spec
index 27c5241..111b017 100644
--- a/php-horde-Horde-Vfs.spec
+++ b/php-horde-Horde-Vfs.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-horde-Horde-Vfs
#
-# Copyright (c) 2012-2017 Nick Bebout, Remi Collet
+# Copyright (c) 2012-2020 Nick Bebout, Remi Collet
#
# License: MIT
# https://fedoraproject.org/wiki/Licensing:MIT#Modern_Style_with_sublicense
@@ -14,16 +14,14 @@
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: php-horde-Horde-Vfs
-Version: 2.4.0
+Version: 2.4.1
Release: 1%{?dist}
Summary: Virtual File System API
-Group: Development/Libraries
License: LGPLv2
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
BuildRequires: php(language) >= 5.3.0
BuildRequires: php-pear(PEAR) >= 1.7.0
@@ -31,8 +29,13 @@ BuildRequires: php-channel(%{pear_channel})
BuildRequires: gettext
%if %{with_tests}
# To run unit tests
-BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
-BuildRequires: php-pear(%{pear_channel}/Horde_Db) >= 2.4.0
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-pear(%{pear_channel}/Horde_Test) >= 2.1.0 with php-pear(%{pear_channel}/Horde_Test) < 3)
+BuildRequires: (php-pear(%{pear_channel}/Horde_Db) >= 2.4.0 with php-pear(%{pear_channel}/Horde_Db) < 3)
+%else
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Db) >= 2.4.0
+%endif
%endif
Requires(post): %{__pear}
@@ -43,24 +46,34 @@ Requires: php-pcre
Requires: php-posix
Requires: php-pear(PEAR) >= 1.7.0
Requires: php-channel(%{pear_channel})
-Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
-Requires: php-pear(%{pear_channel}/Horde_Exception) < 3.0.0
-Requires: php-pear(%{pear_channel}/Horde_Translation) >= 2.2.0
-Requires: php-pear(%{pear_channel}/Horde_Translation) < 3.0.0
-Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
-Requires: php-pear(%{pear_channel}/Horde_Util) < 3.0.0
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Exception) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Translation) >= 2.2.0 with php-pear(%{pear_channel}/Horde_Translation) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Util) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Util) < 3)
# Optional
-Requires: php-ftp
-# https://bugzilla.redhat.com/1023989 update to 0.12 in EPEL-6
-Requires: php-pecl(ssh2) >= 0.12
-Requires: php-pear(%{pear_channel}/Horde_Auth) >= 2.0.0
-Requires: php-pear(%{pear_channel}/Horde_Auth) < 3.0.0
-Requires: php-pear(%{pear_channel}/Horde_Db) >= 2.4.0
-Requires: php-pear(%{pear_channel}/Horde_Db) < 3.0.0
-Requires: php-pear(%{pear_channel}/Horde_Kolab_Session) >= 2.0.0
+Recommends: php-ftp
+Recommends: php-pecl(ssh2) >= 0.12
+Recommends: (php-pear(%{pear_channel}/Horde_Auth) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Auth) < 3)
+Recommends: (php-pear(%{pear_channel}/Horde_Db) >= 2.4.0 with php-pear(%{pear_channel}/Horde_Db) < 3)
+Recommends: (php-pear(%{pear_channel}/Horde_Kolab_Session) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Kolab_Session) < 3)
+Recommends: (php-pear(%{pear_channel}/Horde_Perms) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Perms) < 3)
+%else
+Requires: php-pear(%{pear_channel}/Horde_Exception) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Translation) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Translation) >= 2.2.0
+Requires: php-pear(%{pear_channel}/Horde_Util) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
+# Optional
+Requires: php-pear(%{pear_channel}/Horde_Auth) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Auth) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Db) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Db) >= 2.4.0
Requires: php-pear(%{pear_channel}/Horde_Kolab_Session) < 3.0.0
-Requires: php-pear(%{pear_channel}/Horde_Perms) >= 2.0.0
-Requires: php-pear(%{pear_channel}/Horde_Perms) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Kolab_Session) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Perms) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Perms) >= 2.0.0
+%endif
# Optional and skiped to avoid circular dependency: Horde_Core
# Optional and implicitly required: Horde_Db, Horde_Mime, Horde_Mime
@@ -134,21 +147,13 @@ cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
sed -e 's/testDeleteUnusalFileNames/SKIP_testDeleteUnusalFileNames/' \
-i FileTest.php
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit . || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit . || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose .
-# remirepo:2
-fi
+# TODO: php80
+for cmd in php php72 php73 php74; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --bootstrap bootstrap.php --verbose . || ret=1
+ fi
+done
exit $ret
%else
: Test disabled
@@ -167,19 +172,22 @@ fi
%files -f %{pear_name}.lang
-%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
%{_bindir}/horde-vfs
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/Vfs
%{pear_phpdir}/Horde/Vfs.php
-%{pear_testdir}/%{pear_name}
+%doc %{pear_testdir}/%{pear_name}
%dir %{pear_datadir}/%{pear_name}
%dir %{pear_datadir}/%{pear_name}/locale
%{pear_datadir}/%{pear_name}/migration
%changelog
+* Wed Oct 14 2020 Remi Collet <remi@remirepo.net> - 2.4.1-1
+- update to 2.4.1
+- use weak and range dependencies
+
* Mon Feb 27 2017 Remi Collet <remi@fedoraproject.org> - 2.4.0-1
- Update to 2.4.0
- raise dependency on Horde_Db 2.4.0