summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-10-17 15:27:12 +0200
committerRemi Collet <remi@remirepo.net>2019-10-17 15:27:12 +0200
commit41646e611e586e3918b7c9e7bde1696fa7899c23 (patch)
tree392282e4deba1eae3aa09bd4c0aaffa198f13b1a
parent7519a8bac81af0105a46eaa3dddb97b16bed0872 (diff)
another patch for PHP 7.4
-rw-r--r--2.patch27
-rw-r--r--php-horde-Horde-Util.spec8
2 files changed, 32 insertions, 3 deletions
diff --git a/2.patch b/2.patch
index fc154f1..0f5cfe8 100644
--- a/2.patch
+++ b/2.patch
@@ -1,7 +1,7 @@
From 70e66e65fd0739f7176793b013101b0120e19ee8 Mon Sep 17 00:00:00 2001
From: Remi Collet <remi@remirepo.net>
Date: Tue, 1 Oct 2019 14:56:42 +0200
-Subject: [PATCH] Fix Function get_magic_quotes_gpc() is deprecated (7.4)
+Subject: [PATCH 1/2] Fix Function get_magic_quotes_gpc() is deprecated (7.4)
---
lib/Horde/Util.php | 2 +-
@@ -20,3 +20,28 @@ index 4d16bb8..d6067a1 100644
}
if (self::$_magicquotes) {
+
+From 468e497990e238fd40b88d991762c8a2f8a6c29e Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Thu, 17 Oct 2019 15:18:47 +0200
+Subject: [PATCH 2/2] Fix Invalid characters passed for attempted conversion
+
+New warning raised in PHP 7.4
+as uniqid generated a hexa string, switch to base 16
+---
+ lib/Horde/Util.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/Horde/Util.php b/lib/Horde/Util.php
+index d6067a1..d6d111d 100644
+--- a/lib/Horde/Util.php
++++ b/lib/Horde/Util.php
+@@ -304,7 +304,7 @@ public static function createTempDir($delete = true, $temp_dir = null)
+ /* Get the first 8 characters of a random string to use as a temporary
+ directory name. */
+ do {
+- $new_dir = $temp_dir . '/' . substr(base_convert(uniqid(mt_rand()), 10, 36), 0, 8);
++ $new_dir = $temp_dir . '/' . substr(base_convert(uniqid(mt_rand()), 16, 36), 0, 8);
+ } while (file_exists($new_dir));
+
+ $old_umask = umask(0000);
diff --git a/php-horde-Horde-Util.spec b/php-horde-Horde-Util.spec
index c4940c7..5021abd 100644
--- a/php-horde-Horde-Util.spec
+++ b/php-horde-Horde-Util.spec
@@ -19,7 +19,7 @@
Name: php-horde-Horde-Util
Version: 2.5.8
-Release: 11%{?dist}
+Release: 12%{?dist}
Summary: Horde Utility Libraries
License: LGPLv2
@@ -146,8 +146,12 @@ fi
%changelog
+* Thu Oct 17 2019 Remi Collet <remi@remirepo.net> - 2.5.8-12
+- another patch for PHP 7.4 from
+ https://github.com/horde/Util/pull/2
+
* Tue Oct 1 2019 Remi Collet <remi@remirepo.net> - 2.5.8-11
-- add patch for PHP 7.2 from
+- add patch for PHP 7.4 from
https://github.com/horde/Util/pull/2
* Fri Jan 4 2019 Remi Collet <remi@remirepo.net> - 2.5.8-8