summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-01 19:07:53 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-01 19:07:53 +0100
commite53b618028aff1d17ae2f7418eb5478aad199ed2 (patch)
treeb8a717ba0179bbe38826dc6011e1fb927f586892
parentc39862b54e408f36f2b691706f1a057cb0d07525 (diff)
php-horde-Horde-Token: 2.0.0
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-Token.spec72
2 files changed, 50 insertions, 26 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-Token.spec b/php-horde-Horde-Token.spec
index b6fe25a..e20a429 100644
--- a/php-horde-Horde-Token.spec
+++ b/php-horde-Horde-Token.spec
@@ -1,44 +1,52 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
-%global pear_name Horde_Token
+%global pear_name Horde_Token
+%global pear_channel pear.horde.org
Name: php-horde-Horde-Token
-Version: 1.1.7
+Version: 2.0.0
Release: 1%{?dist}
Summary: Horde Token API
Group: Development/Libraries
License: LGPLv2+
URL: http://pear.horde.org
-Source0: http://pear.horde.org/get/%{pear_name}-%{version}.tgz
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
-BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-pear
+BuildRequires: php-channel(%{pear_channel})
+
Requires(post): %{__pear}
Requires(postun): %{__pear}
-Provides: php-pear(pear.horde.org/%{pear_name}) = %{version}
-Requires: php-pear(pear.horde.org/Horde_Exception) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Translation) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Url) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Util) < 2.0.0
-Requires: php-pear(PEAR) >= 1.7.0
-BuildRequires: php-channel(pear.horde.org)
-Requires: php-channel(pear.horde.org)
+Requires: php(language) >= 5.3.0
+Requires: php-hash
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Translation) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Translation) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Url) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Url) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Util) >= 3.0.0
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
%description
The Horde_Token:: class provides a common abstracted interface into the
various token generation mediums. It also includes all of the functions for
retrieving, storing, and checking tokens.
-%prep
-%setup -q -c
-[ -f package2.xml ] || mv package.xml package2.xml
-mv package2.xml %{pear_name}-%{version}/%{name}.xml
-# Create a "localized" php.ini to avoid build warning
-cp /etc/php.ini .
-echo "date.timezone=UTC" >>php.ini
+%prep
+%setup -q -c -T
+tar xif %{SOURCE0}
cd %{pear_name}-%{version}
+cp ../package.xml %{name}.xml
%build
@@ -48,14 +56,20 @@ cd %{pear_name}-%{version}
%install
cd %{pear_name}-%{version}
-PHPRC=../php.ini %{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%check
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+# Need Db phpunit AllTests.php
+
%post
%{__pear} install --nodeps --soft --force --register-only \
@@ -64,18 +78,24 @@ install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
%postun
if [ $1 -eq 0 ] ; then
%{__pear} uninstall --nodeps --ignore-errors --register-only \
- pear.horde.org/%{pear_name} >/dev/null || :
+ %{pear_channel}/%{pear_name} >/dev/null || :
fi
+
%files
+%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/Token
%{pear_phpdir}/Horde/Token.php
-%{pear_datadir}/Horde_Token
-%{pear_testdir}/Horde_Token
+%{pear_datadir}/%{pear_name}
+%{pear_testdir}/%{pear_name}
+
%changelog
+* Thu Nov 1 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.0-1
+- Update to 2.0.0 for remi repo
+
* Thu Jun 21 2012 Nick Bebout <nb@fedoraproject.org> - 1.1.7-1
- Upgrade to 1.1.7