summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Text-Flowed.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-horde-Horde-Text-Flowed.spec')
-rw-r--r--php-horde-Horde-Text-Flowed.spec33
1 files changed, 22 insertions, 11 deletions
diff --git a/php-horde-Horde-Text-Flowed.spec b/php-horde-Horde-Text-Flowed.spec
index 7fc2ea6..763739c 100644
--- a/php-horde-Horde-Text-Flowed.spec
+++ b/php-horde-Horde-Text-Flowed.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-horde-Horde-Text-Flowed
#
-# Copyright (c) 2012-2017 Nick Bebout, Remi Collet
+# Copyright (c) 2012-2019 Nick Bebout, Remi Collet
#
# License: MIT
# https://fedoraproject.org/wiki/Licensing:MIT#Modern_Style_with_sublicense
@@ -12,23 +12,26 @@
%global pear_channel pear.horde.org
Name: php-horde-Horde-Text-Flowed
-Version: 2.0.3
-Release: 4%{?dist}
+Version: 2.0.4
+Release: 1%{?dist}
Summary: Horde API for flowed text as per RFC 3676
-Group: Development/Libraries
License: LGPLv2
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-Patch0: https://github.com/horde/Text_Flowed/commit/d64eb3a776eb017caa7a504ac4b4d9608bfcf1cc.patch
-
BuildArch: noarch
BuildRequires: php-pear(PEAR) >= 1.7.0
BuildRequires: php(language) >= 5.3.0
BuildRequires: php-channel(%{pear_channel})
# To run unit tests
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-pear(%{pear_channel}/Horde_Test) >= 2.1.0 with php-pear(%{pear_channel}/Horde_Test) < 3)
+BuildRequires: (php-pear(%{pear_channel}/Horde_Util) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Util) < 3)
+%else
BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
+Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
+%endif
Requires(post): %{__pear}
Requires(postun): %{__pear}
@@ -36,8 +39,12 @@ Requires: php(language) >= 5.3.0
Requires: php-pcre
Requires: php-pear(PEAR) >= 1.7.0
Requires: php-channel(%{pear_channel})
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-pear(%{pear_channel}/Horde_Util) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Util) < 3)
+%else
Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Util) < 3.0.0
+%endif
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
Provides: php-composer(horde/horde-text-flowed) = %{version}
@@ -52,9 +59,7 @@ using the encoding described in RFC 3676 ('flowed' text).
%setup -q -c
cd %{pear_name}-%{version}
-%patch0 -p1 -b .upstream
-
-sed -e 's/md5sum="[^"]*"//' ../package.xml >%{name}.xml
+mv ../package.xml %{name}.xml
%build
@@ -78,9 +83,11 @@ install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
ret=0
-for cmd in php php56 php70 php71 php72; do
+for cmd in php php56 php70 php71 php72 php73 php74; do
if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose . || ret=1
+ $cmd %{_bindir}/phpunit \
+ --bootstrap=bootstrap.php \
+ --verbose . || ret=1
fi
done
exit $ret
@@ -105,6 +112,10 @@ fi
%changelog
+* Mon Dec 16 2019 Remi Collet <remi@remirepo.net> - 2.0.4-1
+- update to 2.0.4
+- use range dependencies
+
* Tue Dec 19 2017 Remi Collet <remi@remirepo.net> - 2.0.3-4
- Fix FTBFS from Koschei, add upstream patch for PHP 7.2