summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Text-Flowed.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-02 06:49:50 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-02 06:49:50 +0100
commite1cef8bddcf3de2a67bb84837761efcf6246a6df (patch)
tree31b0fac062c2949090fa76f452638bf0d462a30e /php-horde-Horde-Text-Flowed.spec
php-horde-Horde-Text-Flowed: import from review
Diffstat (limited to 'php-horde-Horde-Text-Flowed.spec')
-rw-r--r--php-horde-Horde-Text-Flowed.spec77
1 files changed, 77 insertions, 0 deletions
diff --git a/php-horde-Horde-Text-Flowed.spec b/php-horde-Horde-Text-Flowed.spec
new file mode 100644
index 0000000..55a768c
--- /dev/null
+++ b/php-horde-Horde-Text-Flowed.spec
@@ -0,0 +1,77 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Horde_Text_Flowed
+
+Name: php-horde-Horde-Text-Flowed
+Version: 1.0.1
+Release: 1%{?dist}
+Summary: Horde API for flowed text as per RFC 3676
+
+Group: Development/Libraries
+License: LGPLv2+
+URL: http://pear.horde.org
+Source0: http://pear.horde.org/get/%{pear_name}-%{version}.tgz
+
+BuildArch: noarch
+BuildRequires: php-pear(PEAR) >= 1.7.0
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Provides: php-pear(pear.horde.org/%{pear_name}) = %{version}
+Requires: php-pear(pear.horde.org/Horde_Util) < 2.0.0
+Requires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-channel(pear.horde.org)
+Requires: php-channel(pear.horde.org)
+
+%description
+The Horde_Text_Flowed:: class provides common methods for manipulating text
+using the encoding described in RFC 3676 ('flowed' text).
+
+%prep
+%setup -q -c
+[ -f package2.xml ] || mv package.xml package2.xml
+mv package2.xml %{pear_name}-%{version}/%{name}.xml
+
+# Create a "localized" php.ini to avoid build warning
+cp /etc/php.ini .
+echo "date.timezone=UTC" >>php.ini
+
+cd %{pear_name}-%{version}
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+PHPRC=../php.ini %{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+
+# Clean up unnecessary files
+rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+
+# Install XML package description
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ pear.horde.org/%{pear_name} >/dev/null || :
+fi
+
+%files
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/Text
+%{pear_testdir}/Horde_Text_Flowed
+%doc %{pear_docdir}/Horde_Text_Flowed/COPYING
+
+%changelog
+* Thu Jun 21 2012 Nick Bebout <nb@fedoraproject.org> - 1.0.1-1
+- Upgrade to 1.0.1
+
+* Sat Jan 28 2012 Nick Bebout <nb@fedoraproject.org> - 1.0.0-1
+- Initial package