summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-06-08 09:49:19 +0200
committerRemi Collet <fedora@famillecollet.com>2014-06-08 09:49:19 +0200
commit8bb1815661360956d59ca441b37c8e7b9b520325 (patch)
treec97feef38b77e0e3d7a1af00d941dcf3f4ddab66
parent33ea3b314b93fefe9494da18db84b25a8335d553 (diff)
horde: fix FTBFS (include path) + cleanups
-rw-r--r--php-horde-Horde-Text-Flowed.spec19
1 files changed, 14 insertions, 5 deletions
diff --git a/php-horde-Horde-Text-Flowed.spec b/php-horde-Horde-Text-Flowed.spec
index 22d85c5..7f641ab 100644
--- a/php-horde-Horde-Text-Flowed.spec
+++ b/php-horde-Horde-Text-Flowed.spec
@@ -1,5 +1,13 @@
-%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
-%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+# spec file for php-horde-Horde-Text-Flowed
+#
+# Copyright (c) 2012-2014 Nick Bebout, Remi Collet
+#
+# License: MIT
+# https://fedoraproject.org/wiki/Licensing:MIT#Modern_Style_with_sublicense
+#
+# Please, preserve the changelog entries
+#
+%{!?__pear: %global __pear %{_bindir}/pear}
%global pear_name Horde_Text_Flowed
%global pear_channel pear.horde.org
@@ -28,7 +36,7 @@ Requires: php-pcre
Requires: php-pear(PEAR) >= 1.7.0
Requires: php-channel(%{pear_channel})
Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
-Conflicts: php-pear(%{pear_channel}/Horde_Util) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) < 3.0.0
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
@@ -64,9 +72,10 @@ install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
+src=$(pwd)/%{pear_name}-%{version}
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-phpunit\
- -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
+phpunit \
+ --include-path=$src/lib \
-d date.timezone=UTC \
.