summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-06-08 09:49:19 +0200
committerRemi Collet <fedora@famillecollet.com>2014-06-08 09:49:19 +0200
commit578f1a7fc06885590f47c6eae7185d76eb33ba7e (patch)
tree1ac48bc505e86f7a24c0c809862928b52ce71f41
parent24829181755fb8c459ab68b43a747f6a19173079 (diff)
horde: fix FTBFS (include path) + cleanups
-rw-r--r--php-horde-Horde-Text-Diff.spec17
1 files changed, 13 insertions, 4 deletions
diff --git a/php-horde-Horde-Text-Diff.spec b/php-horde-Horde-Text-Diff.spec
index 59d10af..64bcb67 100644
--- a/php-horde-Horde-Text-Diff.spec
+++ b/php-horde-Horde-Text-Diff.spec
@@ -1,4 +1,13 @@
-%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+# spec file for php-horde-Horde-Text-Diff
+#
+# Copyright (c) 2012-2014 Nick Bebout, Remi Collet
+#
+# License: MIT
+# https://fedoraproject.org/wiki/Licensing:MIT#Modern_Style_with_sublicense
+#
+# Please, preserve the changelog entries
+#
+%{!?__pear: %global __pear %{_bindir}/pear}
%global pear_name Horde_Text_Diff
%global pear_channel pear.horde.org
@@ -27,9 +36,9 @@ Requires: php-pcre
Requires: php-pear(PEAR) >= 1.7.0
Requires: php-channel(%{pear_channel})
Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
-Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
-Conflicts: php-pear(%{pear_channel}/Horde_Util) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) < 3.0.0
# Optional but not yet available : php-pecl-xdiff
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
@@ -68,7 +77,7 @@ install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
src=$(pwd)/%{pear_name}-%{version}
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
phpunit \
- -d include_path=$src/lib:.:%{pear_phpdir} \
+ --include-path=$src/lib \
-d date.timezone=UTC \
.