summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Horde_Test-upstream.patch36
-rw-r--r--php-horde-Horde-Test.spec9
2 files changed, 44 insertions, 1 deletions
diff --git a/Horde_Test-upstream.patch b/Horde_Test-upstream.patch
new file mode 100644
index 0000000..4603987
--- /dev/null
+++ b/Horde_Test-upstream.patch
@@ -0,0 +1,36 @@
+From af8a2dbe5decff46a19ae0e5a7ff5d3efff1dcb1 Mon Sep 17 00:00:00 2001
+From: Jan Schneider <jan@horde.org>
+Date: Mon, 10 Nov 2014 09:07:18 +0100
+Subject: [PATCH] [jan] Add convertUsername() to Horde_Test_Stub_Registry.
+
+---
+ framework/Test/lib/Horde/Test/Stub/Registry.php | 15 +++++++++++++++
+ framework/Test/package.xml | 4 ++--
+ 2 files changed, 17 insertions(+), 2 deletions(-)
+
+diff --git a/framework/Test/lib/Horde/Test/Stub/Registry.php b/framework/Test/lib/Horde/Test/Stub/Registry.php
+index 6a71e14..e76c262 100644
+--- a/framework/Test/lib/Horde/Test/Stub/Registry.php
++++ b/framework/Test/lib/Horde/Test/Stub/Registry.php
+@@ -58,6 +58,21 @@ public function __construct($user, $app)
+ }
+
+ /**
++ * Converts an authentication username to a unique Horde username.
++ *
++ * @param string $userId The username to convert.
++ * @param boolean $toHorde If true, convert to a Horde username. If
++ * false, convert to the auth username.
++ *
++ * @return string The converted username.
++ * @throws Horde_Exception
++ */
++ public function convertUsername($userId, $toHorde)
++ {
++ return $userId;
++ }
++
++ /**
+ * Returns the currently logged in user, if there is one.
+ *
+ * @param string $format The return format, defaults to the unique Horde
diff --git a/php-horde-Horde-Test.spec b/php-horde-Horde-Test.spec
index 8a41517..d627a54 100644
--- a/php-horde-Horde-Test.spec
+++ b/php-horde-Horde-Test.spec
@@ -13,7 +13,7 @@
Name: php-horde-Horde-Test
Version: 2.4.5
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Horde testing base classes
Group: Development/Libraries
@@ -23,6 +23,7 @@ Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
# Use unbundled PHPUnit
Patch0: %{pear_name}-rpm.patch
+Patch1: %{pear_name}-upstream.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
@@ -66,12 +67,14 @@ Horde-specific PHPUnit base classes.
cd %{pear_name}-%{version}
%patch0 -p1 -b .rpm
+%patch1 -p3 -b .upstream
# Don't install bundled PHPUnit
# Don't check md5sum for patched files
sed -e '/bundle\/vendor/d' \
-e '/Autoload.php/s/md5sum="[^"]*"//' \
-e '/AllTests.php/s/md5sum="[^"]*"//' \
+ -e '/Registry.php/s/md5sum="[^"]*"//' \
../package.xml >%{name}.xml
touch -r ../package.xml %{name}.xml
@@ -112,6 +115,10 @@ fi
%changelog
+* Mon Nov 10 2014 Remi Collet <remi@fedoraproject.org> - 2.4.5-2
+- add upstream patch to fix test failure in turba
+ and kronolith, thanks to Koschei
+
* Tue Oct 28 2014 Remi Collet <remi@fedoraproject.org> - 2.4.5-1
- Update to 2.4.5