summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-01 13:28:40 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-01 13:28:40 +0100
commit2f2403c9b9e4a2420d4c0046a951c5560e333f54 (patch)
tree135480622674aeed3992e81f882b67d21e0ea030
php-horde-Horde-Test: import from review, update to 2.0.0
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-Test.spec94
2 files changed, 98 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-Test.spec b/php-horde-Horde-Test.spec
new file mode 100644
index 0000000..3641225
--- /dev/null
+++ b/php-horde-Horde-Test.spec
@@ -0,0 +1,94 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Horde_Test
+%global pear_channel pear.horde.org
+
+Name: php-horde-Horde-Test
+Version: 2.0.0
+Release: 1%{?dist}
+Summary: Horde testing base classes
+
+Group: Development/Libraries
+License: LGPLv2+
+URL: http://pear.horde.org
+Source0: http://pear.horde.org/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildArch: noarch
+BuildRequires: php-pear
+BuildRequires: php-channel(%{pear_channel})
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php(language) >= 5.3.0
+Requires: php-pear(%{pear_channel}/Horde_Support) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Support) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Util) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Cli) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Cli) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Log) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Log) >= 3.0.0
+Requires: php-pear(pear.phpunit.de/PHPUnit) >= 3.5.0
+Requires: php-channel(%{pear_channel})
+Requires: php-pdo php-dom php-spl php-json php-pcre
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+%description
+Horde-specific PHPUnit base classes.
+
+%prep
+%setup -q -c -T
+tar xif %{SOURCE0}
+
+cd %{pear_name}-%{version}
+mv ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/Test
+
+
+%changelog
+* Thu Nov 1 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.0-1
+- Update to 2.0.0 for remi repo
+
+* Mon Jun 25 2012 Nick Bebout <nb@fedoraproject.org> - 1.3.0-3
+- Fix requires
+
+* Wed Jun 20 2012 Nick Bebout <nb@fedoraproject.org> - 1.3.0-2
+- Fix packaging issues
+
+* Sat Jan 28 2012 Nick Bebout <nb@fedoraproject.org> - 1.3.0-1
+- Initial package