summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-01-09 14:20:40 +0100
committerRemi Collet <fedora@famillecollet.com>2015-01-09 14:20:40 +0100
commitb9fbf2835b98b8ef02b8b102d46af92db033df0c (patch)
treef51caf9945c3e04aef7de4a154f9bafac16a707a
parentab79acb017f180730e21bfd861e2c01cd036c72b (diff)
php-horde-Horde-Support: 2.1.2
-rw-r--r--php-horde-Horde-Support.spec32
1 files changed, 24 insertions, 8 deletions
diff --git a/php-horde-Horde-Support.spec b/php-horde-Horde-Support.spec
index 7169a1a..30eb9b1 100644
--- a/php-horde-Horde-Support.spec
+++ b/php-horde-Horde-Support.spec
@@ -1,12 +1,24 @@
-%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+# spec file for php-horde-Horde-Support
+#
+# Copyright (c) 2012-2015 Nick Bebout, Remi Collet
+#
+# License: MIT
+# https://fedoraproject.org/wiki/Licensing:MIT#Modern_Style_with_sublicense
+#
+# Please, preserve the changelog entries
+#
+%{!?__pear: %global __pear %{_bindir}/pear}
+%global bootstrap 0
%global pear_name Horde_Support
%global pear_channel pear.horde.org
-
-# Can run test because of circular dependency with Horde_Test
+%if %{bootstrap}
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%else
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%endif
Name: php-horde-Horde-Support
-Version: 2.1.1
+Version: 2.1.2
Release: 1%{?dist}
Summary: Horde support package
@@ -39,6 +51,8 @@ Requires: php-pear(%{pear_channel}/Horde_Stream_Wrapper) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Stream_Wrapper) < 3.0.0
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+Provides: php-composer(horde/horde-support) = %{version}
+
%description
Support classes not tied to Horde but is used by it. These classes can be
@@ -75,10 +89,7 @@ install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
%if %{with_tests}
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-phpunit\
- -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
- -d date.timezone=UTC \
- .
+phpunit .
%else
: Test disabled, missing '--with tests' option.
%endif
@@ -104,6 +115,11 @@ fi
%changelog
+* Fri Jan 09 2015 Remi Collet <remi@fedoraproject.org> - 2.1.2-1
+- Update to 2.1.2
+- add provides php-composer(horde/horde-support)
+- enable test suite
+
* Sun Sep 08 2013 Remi Collet <remi@fedoraproject.org> - 2.1.1-1
- Update to 2.1.1