summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-03 09:48:43 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-03 09:48:43 +0100
commit53d2b384b486fcbc48c0860d2005dbd93a6e3ae6 (patch)
tree91dfee1b02c93455690e4058e79e2fedfead1231
php-horde-Horde-Stream: new package
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-Stream.spec97
2 files changed, 101 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-Stream.spec b/php-horde-Horde-Stream.spec
new file mode 100644
index 0000000..2b581ff
--- /dev/null
+++ b/php-horde-Horde-Stream.spec
@@ -0,0 +1,97 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Horde_Stream
+%global pear_channel pear.horde.org
+
+Name: php-horde-Horde-Stream
+Version: 1.0.0
+Release: 1%{?dist}
+Summary: Horde stream handler
+
+Group: Development/Libraries
+License: LGPL-2.1
+URL: http://pear.horde.org
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php-pear
+BuildRequires: php-channel(%{pear_channel})
+# To run unit tests
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.0.0
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php(language) >= 5.3.0
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+
+%description
+An object-oriented interface to assist in creating and storing PHP stream
+resources, and to provide utility methods to access and manipulate the
+stream contents.
+
+
+%prep
+%setup -q -c -T
+tar xif %{SOURCE0}
+
+cd %{pear_name}-%{version}
+cp ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%check
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+phpunit -d date.timezone=UTC AllTests.php
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/Stream
+%{pear_phpdir}/Horde/Stream.php
+%{pear_testdir}/%{pear_name}
+
+
+%changelog
+* Sat Nov 3 2012 Remi Collet <RPMS@FamilleCollet.com> - 3.0.0-1
+- Initial package
+