summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-SpellChecker.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-horde-Horde-SpellChecker.spec')
-rw-r--r--php-horde-Horde-SpellChecker.spec21
1 files changed, 16 insertions, 5 deletions
diff --git a/php-horde-Horde-SpellChecker.spec b/php-horde-Horde-SpellChecker.spec
index 8d40500..9392b48 100644
--- a/php-horde-Horde-SpellChecker.spec
+++ b/php-horde-Horde-SpellChecker.spec
@@ -1,10 +1,18 @@
+# spec file for php-horde-Horde-SpellChecker
+#
+# Copyright (c) 2013 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
%global pear_name Horde_SpellChecker
%global pear_channel pear.horde.org
Name: php-horde-Horde-SpellChecker
-Version: 2.1.0
+Version: 2.1.1
Release: 1%{?dist}
Summary: Spellcheck API
@@ -15,7 +23,7 @@ Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
-BuildRequires: php-common >= 5.3.0
+BuildRequires: php(language) >= 5.3.0
BuildRequires: php-pear(PEAR) >= 1.7.0
BuildRequires: php-channel(%{pear_channel})
# To run unit tests
@@ -26,14 +34,14 @@ BuildRequires: aspell-en
Requires(post): %{__pear}
Requires(postun): %{__pear}
Requires: aspell
-Requires: php-common >= 5.3.0
+Requires: php(language) >= 5.3.0
Requires: php-pcre
Requires: php-pear(PEAR) >= 1.7.0
Requires: php-channel(%{pear_channel})
Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
-Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
-Conflicts: php-pear(%{pear_channel}/Horde_Util) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) < 3.0.0
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
@@ -100,5 +108,8 @@ fi
%changelog
+* Tue Oct 15 2013 Remi Collet <remi@fedoraproject.org> - 2.1.1-1
+- Update to 2.1.1
+
* Sat Jan 12 2013 Remi Collet <remi@fedoraproject.org> - 2.1.0-1
- Initial package