summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-01-12 08:54:12 +0100
committerRemi Collet <fedora@famillecollet.com>2013-01-12 08:54:12 +0100
commitabe4bf4ad2e5757dc1e8b1007799c5a4d7b2fdb1 (patch)
tree3993b921c79566763a164c3ea4f24824249cf3b8
php-horde-Horde-SpellChecker: new package
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-SpellChecker.spec104
2 files changed, 108 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-SpellChecker.spec b/php-horde-Horde-SpellChecker.spec
new file mode 100644
index 0000000..8d40500
--- /dev/null
+++ b/php-horde-Horde-SpellChecker.spec
@@ -0,0 +1,104 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Horde_SpellChecker
+%global pear_channel pear.horde.org
+
+Name: php-horde-Horde-SpellChecker
+Version: 2.1.0
+Release: 1%{?dist}
+Summary: Spellcheck API
+
+Group: Development/Libraries
+License: LGPLv2
+URL: http://pear.horde.org
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php-common >= 5.3.0
+BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-channel(%{pear_channel})
+# To run unit tests
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
+BuildRequires: aspell
+BuildRequires: aspell-en
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: aspell
+Requires: php-common >= 5.3.0
+Requires: php-pcre
+Requires: php-pear(PEAR) >= 1.7.0
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Util) >= 3.0.0
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+
+%description
+Unified spellchecking API.
+
+
+%prep
+%setup -q -c
+
+cd %{pear_name}-%{version}
+cp ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%check
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+phpunit \
+ -d date.timezone=UTC \
+ -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
+ .
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/SpellChecker
+%{pear_phpdir}/Horde/SpellChecker.php
+%{pear_testdir}/%{pear_name}
+
+
+%changelog
+* Sat Jan 12 2013 Remi Collet <remi@fedoraproject.org> - 2.1.0-1
+- Initial package