summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-10-19 08:44:16 +0200
committerRemi Collet <fedora@famillecollet.com>2013-10-19 08:44:16 +0200
commit79ef8a7857f2021c520c3939e5aab20af1660904 (patch)
tree597c2abbbc060b40e727f9860763cf2be6f0a341
php-horde-Horde-Socket-Client: 1.0.0 New package
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-Socket-Client.spec96
2 files changed, 100 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-Socket-Client.spec b/php-horde-Horde-Socket-Client.spec
new file mode 100644
index 0000000..d0755cb
--- /dev/null
+++ b/php-horde-Horde-Socket-Client.spec
@@ -0,0 +1,96 @@
+# spec file for php-horde-Horde-Socket-Client
+#
+# Copyright (c) 2013 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %global __pear %{_bindir}/pear}
+%global pear_name Horde_Socket_Client
+%global pear_channel pear.horde.org
+
+Name: php-horde-Horde-Socket-Client
+Version: 1.0.0
+Release: 1%{?dist}
+Summary: Horde Socket Client
+
+Group: Development/Libraries
+License: LGPLv2
+URL: http://%{pear_channel}
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 5.3.0
+BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-channel(%{pear_channel})
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php(language) >= 5.3.0
+Requires: php-openssl
+Requires: php-spl
+Requires: php-pear(PEAR) >= 1.7.0
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) < 3.0.0
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+
+%description
+Provides abstract class for use in creating PHP network socket clients.
+
+%prep
+%setup -q -c
+
+cd %{pear_name}-%{version}
+mv ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/Socket
+
+
+%changelog
+* Sat Oct 19 2013 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- initial package, version 1.0.0 (stable)
+