summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-horde-Horde-Smtp.spec62
1 files changed, 40 insertions, 22 deletions
diff --git a/php-horde-Horde-Smtp.spec b/php-horde-Horde-Smtp.spec
index 71af201..6f02000 100644
--- a/php-horde-Horde-Smtp.spec
+++ b/php-horde-Horde-Smtp.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-horde-Horde-Smtp
#
-# Copyright (c) 2013-2017 Remi Collet
+# Copyright (c) 2013-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -11,11 +11,10 @@
%global pear_channel pear.horde.org
Name: php-horde-Horde-Smtp
-Version: 1.9.5
+Version: 1.9.6
Release: 1%{?dist}
Summary: Horde SMTP Client
-Group: Development/Libraries
License: LGPLv2
URL: http://%{pear_channel}
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
@@ -26,35 +25,50 @@ BuildRequires: php(language) >= 5.3.0
BuildRequires: php-pear(PEAR) >= 1.7.0
BuildRequires: php-channel(%{pear_channel})
# To run unit tests
-BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-pear(%{pear_channel}/Horde_Test) >= 2.1.0 with php-pear(%{pear_channel}/Horde_Test) < 3)
+%else
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
+%endif
Requires(post): %{__pear}
Requires(postun): %{__pear}
Requires: php(language) >= 5.3.0
Requires: php-pear(PEAR) >= 1.7.0
Requires: php-channel(pear.horde.org)
-Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
-Requires: php-pear(%{pear_channel}/Horde_Exception) < 3.0.0
-Requires: php-pear(%{pear_channel}/Horde_Mail) >= 2.0.0
-Requires: php-pear(%{pear_channel}/Horde_Mail) < 3.0.0
-Requires: php-pear(%{pear_channel}/Horde_Support) >= 2.0.0
-Requires: php-pear(%{pear_channel}/Horde_Support) < 3.0.0
-Requires: php-pear(%{pear_channel}/Horde_Translation) >= 2.2.0
-Requires: php-pear(%{pear_channel}/Horde_Translation) < 3.0.0
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Exception) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Mail) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Mail) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Support) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Support) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Translation) >= 2.2.0 with php-pear(%{pear_channel}/Horde_Translation) < 3)
+# Optional
+Recommends: (php-pear(%{pear_channel}/Horde_Imap_Client) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Imap_Client) < 3)
+Recommends: (php-pear(%{pear_channel}/Horde_Socket_Client) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Socket_Client) < 3)
+Recommends: (php-pear(%{pear_channel}/Horde_Util) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Util) < 3)
+# Horde_Secret optional and implicitly required
+%else
+Requires: php-pear(%{pear_channel}/Horde_Exception) < 3
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Mail) < 3
+Requires: php-pear(%{pear_channel}/Horde_Mail) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Support) < 3
+Requires: php-pear(%{pear_channel}/Horde_Support) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Translation) < 3
+Requires: php-pear(%{pear_channel}/Horde_Translation) >= 2.2.0
+# Optional
+Requires: php-pear(%{pear_channel}/Horde_Imap_Client) < 3
+Requires: php-pear(%{pear_channel}/Horde_Imap_Client) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Socket_Client) < 3
+Requires: php-pear(%{pear_channel}/Horde_Socket_Client) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) < 3
+Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
+%endif
# From phpcompatinfo report
Requires: php-date
Requires: php-hash
Requires: php-openssl
Requires: php-pcre
Requires: php-spl
-# Optional
-Requires: php-pear(%{pear_channel}/Horde_Imap_Client) >= 2.0.0
-Requires: php-pear(%{pear_channel}/Horde_Imap_Client) < 3.0.0
-Requires: php-pear(%{pear_channel}/Horde_Socket_Client) >= 2.0.0
-Requires: php-pear(%{pear_channel}/Horde_Socket_Client) < 3
-Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
-Requires: php-pear(%{pear_channel}/Horde_Util) < 3.0.0
-# Horde_Secret optional and implicitly required
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
Provides: php-composer(horde/horde-smtp) = %{version}
@@ -108,9 +122,9 @@ done | tee ../%{pear_name}.lang
%check
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
ret=0
-for cmd in php php56 php70 php71 php72; do
+for cmd in php php72 php73 php74; do
if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose . || ret=1
+ $cmd %{_bindir}/phpunit --bootstrap bootstrap.php --verbose . || ret=1
fi
done
exit $ret
@@ -138,6 +152,10 @@ fi
%changelog
+* Mon Nov 23 2020 Remi Collet <remi@remirepo.net> - 1.9.6-1
+- update to 1.9.6
+- use weak and range dependencies
+
* Fri Jun 23 2017 Remi Collet <remi@remirepo.net> - 1.9.5-1
- Update to 1.9.5