summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-04 10:03:02 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-04 10:03:02 +0100
commit2fed00745a39d52fbf1297182e6a5efbda4e9cf1 (patch)
tree1e8dd0255d2369ad075e8b7b023b60194e18042e
parent867fcb6cd2a1c328d3190cc20683be5318519434 (diff)
php-horde-Horde-Share: new package
-rw-r--r--php-horde-Horde-Share.spec135
1 files changed, 135 insertions, 0 deletions
diff --git a/php-horde-Horde-Share.spec b/php-horde-Horde-Share.spec
new file mode 100644
index 0000000..6ddf912
--- /dev/null
+++ b/php-horde-Horde-Share.spec
@@ -0,0 +1,135 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Horde_Share
+%global pear_channel pear.horde.org
+
+Name: php-horde-Horde-Share
+Version: 2.0.0
+Release: 1%{?dist}
+Summary: Horde Shared Permissions System
+
+Group: Development/Libraries
+License: LGPLv2+
+URL: http://pear.horde.org
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+# /usr/lib/rpm/find-lang.sh from fedora 16
+Source1: find-lang.sh
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php-pear
+BuildRequires: php-channel(%{pear_channel})
+BuildRequires: gettext
+# To run unit tests
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.0.0
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php(language) >= 5.3.0
+Requires: php-spl
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Db) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Db) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Group) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Group) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Perms) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Perms) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Support) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Support) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Translation) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Translation) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Url) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Url) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Util) >= 3.0.0
+# Optionnal Horde_Kolab_Storage
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+%description
+Horde_Share provides an interface to all shared resources a user
+owns or has access to.
+
+
+%prep
+%setup -q -c -T
+tar xif %{SOURCE0}
+
+cd %{pear_name}-%{version}
+
+# Don't install .po and .pot files
+# Remove checksum for .mo, as we regenerate them
+sed -e '/%{pear_name}.po/d' \
+ -e '/Horde_Other.po/d' \
+ -e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \
+ ../package.xml >%{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+
+# Regenerate the locales
+for po in $(find locale -name \*.po)
+do
+ msgfmt $po -o $(dirname $po)/$(basename $po .po).mo
+done
+
+
+%install
+cd %{pear_name}-%{version}
+rm -rf %{buildroot}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+%if 0%{?fedora} > 13
+%find_lang %{pear_name}
+%else
+sh %{SOURCE1} %{buildroot} %{pear_name}
+%endif
+
+
+%check
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+# not ready: phpunit -d date.timezone=UTC AllTests.php
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files -f %{pear_name}-%{version}/%{pear_name}.lang
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/Share
+%{pear_testdir}/%{pear_name}
+# own locales (non standard) directories, .mo own by find_lang
+%dir %{pear_datadir}/%{pear_name}
+%dir %{pear_datadir}/%{pear_name}/locale
+%dir %{pear_datadir}/%{pear_name}/locale/*
+%dir %{pear_datadir}/%{pear_name}/locale/*/LC_MESSAGES
+
+
+%changelog
+* Sat Nov 3 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.0-1
+- Initial package
+