summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--3.patch25
-rw-r--r--Autoload.php7
-rw-r--r--php-horde-Horde-SessionHandler.spec15
3 files changed, 16 insertions, 31 deletions
diff --git a/3.patch b/3.patch
deleted file mode 100644
index c7965da..0000000
--- a/3.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 8cb2da6626e84b7e480917ff1d7a5cea140e539d Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 20 Jan 2021 09:03:39 +0100
-Subject: [PATCH] re-add setUpBeforeClass
-
----
- test/Horde/SessionHandler/Storage/Base.php | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/test/Horde/SessionHandler/Storage/Base.php b/test/Horde/SessionHandler/Storage/Base.php
-index f4eb0f3..1148cbb 100644
---- a/test/Horde/SessionHandler/Storage/Base.php
-+++ b/test/Horde/SessionHandler/Storage/Base.php
-@@ -68,6 +68,11 @@ protected function _gc()
- self::$handler->getSessionIDs());
- }
-
-+ public static function setUpBeforeClass()
-+ {
-+ self::$dir = Horde_Util::createTempDir();
-+ }
-+
- public static function tearDownAfterClass()
- {
- self::$handler = null;
diff --git a/Autoload.php b/Autoload.php
new file mode 100644
index 0000000..665bf03
--- /dev/null
+++ b/Autoload.php
@@ -0,0 +1,7 @@
+<?php
+session_cache_limiter('');
+ini_set('session.use_cookies', 0);
+Horde_SessionHandler_Storage_BuiltinTest::$dir = Horde_Util::createTempDir();
+ini_set('session.save_path', Horde_SessionHandler_Storage_BuiltinTest::$dir);
+Horde_SessionHandler_Storage_FileTest::$dir = Horde_Util::createTempDir();
+Horde_SessionHandler_Storage_StackTest::$dir = Horde_Util::createTempDir();
diff --git a/php-horde-Horde-SessionHandler.spec b/php-horde-Horde-SessionHandler.spec
index c162c3e..87edcf5 100644
--- a/php-horde-Horde-SessionHandler.spec
+++ b/php-horde-Horde-SessionHandler.spec
@@ -12,14 +12,14 @@
Name: php-horde-Horde-SessionHandler
Version: 2.3.0
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Horde Session Handler API
License: LGPLv2
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-
-Patch0: https://patch-diff.githubusercontent.com/raw/horde/SessionHandler/pull/3.patch
+# see https://github.com/horde/SessionHandler/pull/4
+Source1: https://raw.githubusercontent.com/horde/SessionHandler/v2.3.0/test/Horde/SessionHandler/Autoload.php
BuildArch: noarch
BuildRequires: php(language) >= 5.3.0
@@ -69,8 +69,8 @@ handlers for PHP.
%setup -q -c
cd %{pear_name}-%{version}
-%patch0 -p1
-sed -e '/Base.php/s/md5sum=.*name=/name=/' ../package.xml >%{name}.xml
+mv ../package.xml %{name}.xml
+cp %{SOURCE1} test/Horde/SessionHandler/Autoload.php
%build
@@ -97,7 +97,6 @@ cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
ret=0
# TODO: php80
-rm -f Storage/BuiltinTest.php
for cmd in php php72 php73 php74; do
if which $cmd; then
$cmd %{_bindir}/phpunit --bootstrap bootstrap.php --verbose . || ret=1
@@ -127,6 +126,10 @@ fi
%changelog
+* Thu Jan 21 2021 Remi Collet <remi@remirepo.net> - 2.3.0-2
+- add missing file for test suite
+ see https://github.com/horde/SessionHandler/pull/4
+
* Wed Jan 20 2021 Remi Collet <remi@remirepo.net> - 2.3.0-1
- update to 2.3.0
- add patch for test suite from