summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-06-05 10:53:28 +0200
committerRemi Collet <fedora@famillecollet.com>2013-06-05 10:53:28 +0200
commit168987fe4048fe30578876059aa70e3b7f5d9b02 (patch)
treeab0d6e6150660b677d6053a1ae516f178dddc1be
parent1b358062cd184bed444116f69e13315e0889a053 (diff)
php-horde-Horde-SessionHandler: 2.2.0
-rw-r--r--php-horde-Horde-SessionHandler.spec32
1 files changed, 23 insertions, 9 deletions
diff --git a/php-horde-Horde-SessionHandler.spec b/php-horde-Horde-SessionHandler.spec
index 07219b9..3111131 100644
--- a/php-horde-Horde-SessionHandler.spec
+++ b/php-horde-Horde-SessionHandler.spec
@@ -1,10 +1,18 @@
+# spec file for php-horde-Horde-Mongo
+#
+# Copyright (c) 2013 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
%global pear_name Horde_SessionHandler
%global pear_channel pear.horde.org
Name: php-horde-Horde-SessionHandler
-Version: 2.1.0
+Version: 2.2.0
Release: 1%{?dist}
Summary: Horde Session Handler API
@@ -29,13 +37,13 @@ Requires: php-date
Requires: php-session
Requires: php-channel(%{pear_channel})
Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
-Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
-Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
-Conflicts: php-pear(%{pear_channel}/Horde_Util) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Support) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Support) < 3.0.0
# Optionnal
Requires: php-pear(%{pear_channel}/Horde_Db) >= 2.0.3
-Conflicts: php-pear(%{pear_channel}/Horde_Db) >= 3.0.0
-# Optional and implicitly required: Horde_Log, Horde_Memcache
+Requires: php-pear(%{pear_channel}/Horde_Db) < 3.0.0
+# Optional and implicitly required: Horde_HashTable, Horde_Log, Horde_Mongo
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
@@ -75,10 +83,10 @@ rm -rf %{buildroot}
%check
-# Some tests fails when memcache extension available, need investigation
+src=$(pwd)/%{pear_name}-%{version}
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-phpunit\
- -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
+phpunit \
+ -d include_path=$src/lib:.:%{pear_phpdir} \
-d date.timezone=UTC \
.
@@ -105,6 +113,12 @@ fi
%changelog
+* Wed Jun 05 2013 Remi Collet <remi@fedoraproject.org> - 2.2.0-1
+- Update to 2.2.0
+- switch from Conflicts to Requires
+- drop Requires Horde_Util
+- add Requires Horde_Support
+
* Tue May 07 2013 Remi Collet <remi@fedoraproject.org> - 2.1.0-1
- Update to 2.1.0
- raise dependency on Horde_Db >= 2.0.3