summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-02 10:02:44 +0100
committerRemi Collet <remi@remirepo.net>2020-12-02 10:02:44 +0100
commit8ef0b0453600da96898d223fd8074f3befe15d2a (patch)
tree4cde54a568e0fa6b4b8d16f2e19f0b82316083fd
parent3f4303fac179113cbb2e01993c43aceba4a6a4ce (diff)
update to 2.5.5HEADmaster
drop patch merged upstream
-rw-r--r--1.patch57
-rw-r--r--php-horde-Horde-Service-Weather.spec15
2 files changed, 8 insertions, 64 deletions
diff --git a/1.patch b/1.patch
deleted file mode 100644
index dd4d677..0000000
--- a/1.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 9b64ea49884ccc67eb00803ea8a8d20bdd71d696 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Mon, 18 Nov 2019 14:26:48 +0100
-Subject: [PATCH] fix phplint warnings
-
----
- lib/Horde/Service/Weather.php | 6 +++---
- lib/Horde/Service/Weather/Parser/Metar.php | 8 ++++----
- 2 files changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/lib/Horde/Service/Weather.php b/lib/Horde/Service/Weather.php
-index 0a9d44f..2a7c423 100644
---- a/lib/Horde/Service/Weather.php
-+++ b/lib/Horde/Service/Weather.php
-@@ -351,8 +351,8 @@ public static function convertTemperature($temperature, $from, $to)
- return $temperature;
- }
-
-- $from = strtolower($from{0});
-- $to = strtolower($to{0});
-+ $from = strtolower($from[0]);
-+ $to = strtolower($to[0]);
-
- $result = array(
- 'f' => array(
-@@ -368,4 +368,4 @@ public static function convertTemperature($temperature, $from, $to)
- return $result[$from][$to];
- }
-
--}
-\ No newline at end of file
-+}
-diff --git a/lib/Horde/Service/Weather/Parser/Metar.php b/lib/Horde/Service/Weather/Parser/Metar.php
-index 570f6c2..61bf73d 100644
---- a/lib/Horde/Service/Weather/Parser/Metar.php
-+++ b/lib/Horde/Service/Weather/Parser/Metar.php
-@@ -545,10 +545,10 @@ protected function _parse(array $data)
- 'presschng' => Horde_Service_Weather::convertPressure($result[2] / 10, 'hpa', $this->_unitMap[self::UNIT_KEY_PRESSURE]),
- 'description' => ($result[1] >= 0 && $result[1] <=3)
- ? Horde_Service_Weather_Translation::t('Rising')
-- : ($result[1] == 4)
-+ : (($result[1] == 4)
- ? Horde_Service_Weather_Translation::t('Steady')
-- : ($result[1] > 4)
-- ? Horde_Service_Weather_Translation::t('Falling') : ''
-+ : (($result[1] > 4)
-+ ? Horde_Service_Weather_Translation::t('Falling') : ''))
- );
- unset($metarCode['3hpresstend']);
- break;
-@@ -637,4 +637,4 @@ protected function _getRemarks()
- );
- }
-
--}
-\ No newline at end of file
-+}
diff --git a/php-horde-Horde-Service-Weather.spec b/php-horde-Horde-Service-Weather.spec
index 23fb5d1..4810594 100644
--- a/php-horde-Horde-Service-Weather.spec
+++ b/php-horde-Horde-Service-Weather.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-horde-Horde-Service-Weather
#
-# Copyright (c) 2012-2019 Remi Collet
+# Copyright (c) 2012-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -11,16 +11,14 @@
%global pear_channel pear.horde.org
Name: php-horde-Horde-Service-Weather
-Version: 2.5.4
-Release: 7%{?dist}
+Version: 2.5.5
+Release: 1%{?dist}
Summary: Horde Weather Provider
License: BSD
URL: http://%{pear_channel}
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-Patch0: https://patch-diff.githubusercontent.com/raw/horde/Service_Weather/pull/1.patch
-
BuildArch: noarch
BuildRequires: gettext
BuildRequires: php(language) >= 5.3.0
@@ -92,7 +90,6 @@ WorldWeatherOnline, and Google Weather.
%setup -q -c
cd %{pear_name}-%{version}
-%patch0 -p1 -b .pr1
# Don't install .po and .pot files
# Remove checksum for .mo, as we regenerate them
@@ -138,7 +135,7 @@ done | tee ../%{pear_name}.lang
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
ret=0
-for cmd in php php71 php72 php73 php74; do
+for cmd in php php72 php73 php74; do
if which $cmd; then
$cmd %{_bindir}/phpunit --bootstrap bootstrap.php --verbose . || ret=1
fi
@@ -172,6 +169,10 @@ fi
%changelog
+* Wed Dec 2 2020 Remi Collet <remi@remirepo.net> - 2.5.5-1
+- update to 2.5.5
+- drop patch merged upstream
+
* Mon Nov 18 2019 Remi Collet <remi@fedoraproject.org> - 2.5.4-7
- Fix FTBFS from Koschei, add patch for PHP 7.4 from
https://github.com/horde/Service_Weather/pull/1