summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-07-10 13:40:25 +0200
committerRemi Collet <fedora@famillecollet.com>2014-07-10 13:40:25 +0200
commit21f21114a1c84d017a516d81172c6b8c116d584b (patch)
tree2f7a107de564a0efc9621bd84546adcafb1a9222
php-horde-Horde-Service-Gravatar: 1.0.0 - New package
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-Service-Gravatar.spec121
2 files changed, 125 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-Service-Gravatar.spec b/php-horde-Horde-Service-Gravatar.spec
new file mode 100644
index 0000000..6de7fdd
--- /dev/null
+++ b/php-horde-Horde-Service-Gravatar.spec
@@ -0,0 +1,121 @@
+# spec file for php-horde-Horde-OpenXchange
+#
+# Copyright (c) 2014 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{!?__pear: %global __pear %{_bindir}/pear}
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%global pear_name Horde_Service_Gravatar
+%global pear_channel pear.horde.org
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+
+Name: php-horde-Horde-Service-Gravatar
+Version: 1.0.0
+Release: 1%{?dist}
+Summary: API accessor for gravatar.com
+
+Group: Development/Libraries
+License: LGPLv2
+URL: http://pear.horde.org/
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 5.3.0
+BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-channel(%{pear_channel})
+%if %{with_tests}
+# To run unit tests
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Http) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Url) >= 2.0.0
+%endif
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+# From package.xml
+Requires: php(language) >= 5.3.0
+Requires: php-pear(PEAR) >= 1.7.0
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Http) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Http) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Url) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Url) < 3.0.0
+# From phpcompatinfo report for version 1.0.0
+Requires: php-json
+Requires: php-spl
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+
+%description
+A library for accessing the Avatar services at gravatar.com.
+
+%prep
+%setup -q -c
+
+cd %{pear_name}-%{version}
+mv ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+rm -rf %{buildroot}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%check
+%if %{with_tests}
+src=$(pwd)/%{pear_name}-%{version}
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+phpunit \
+ --include-path=$src/lib \
+ -d date.timezone=UTC \
+ .
+%else
+: Test disabled, missing '--with tests' option.
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%dir %{pear_phpdir}/Horde/Service/
+%{pear_phpdir}/Horde/Service/Gravatar.php
+%{pear_testdir}/%{pear_name}
+
+
+%changelog
+* Thu Jul 10 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- initial package, version 1.0.0 \ No newline at end of file