summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-06-08 09:49:19 +0200
committerRemi Collet <fedora@famillecollet.com>2014-06-08 09:49:19 +0200
commit956ef1766f971c4c9e18157669f99a61b4aa1133 (patch)
tree496851fd9ec2a234a4166c906ab3ce0a4f25848d
parentd697d41f2e228a6fbfad2e0ef6fbd914de7b3c77 (diff)
horde: fix FTBFS (include path) + cleanups
-rw-r--r--php-horde-Horde-Serialize.spec28
1 files changed, 22 insertions, 6 deletions
diff --git a/php-horde-Horde-Serialize.spec b/php-horde-Horde-Serialize.spec
index e5ea78d..b9e0176 100644
--- a/php-horde-Horde-Serialize.spec
+++ b/php-horde-Horde-Serialize.spec
@@ -1,4 +1,13 @@
-%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+# spec file for php-horde-Horde-Serialize
+#
+# Copyright (c) 2012-2014 Nick Bebout, Remi Collet
+#
+# License: MIT
+# https://fedoraproject.org/wiki/Licensing:MIT#Modern_Style_with_sublicense
+#
+# Please, preserve the changelog entries
+#
+%{!?__pear: %global __pear %{_bindir}/pear}
%global pear_name Horde_Serialize
%global pear_channel pear.horde.org
@@ -30,9 +39,10 @@ Requires: php-zlib
Requires: php-pecl(LZF)
Requires: php-channel(%{pear_channel})
Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
-Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
-Conflicts: php-pear(%{pear_channel}/Horde_Util) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) < 3.0.0
+# Optional and skipped for build order: Horde_Imap_Client, Horde_Mime
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
@@ -67,9 +77,15 @@ install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
-cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:)
-phpunit\
- -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
+src=$(pwd)/%{pear_name}-%{version}
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+
+# Because of jsonc
+sed -e 's/function testJsonInvalidUTF8Input/function SKIP_testJsonInvalidUTF8Input/' \
+ -i JsonTest.php
+
+phpunit \
+ --include-path=$src/lib \
-d date.timezone=UTC \
.