summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Secret.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-horde-Horde-Secret.spec')
-rw-r--r--php-horde-Horde-Secret.spec20
1 files changed, 14 insertions, 6 deletions
diff --git a/php-horde-Horde-Secret.spec b/php-horde-Horde-Secret.spec
index 91fe19f..9cd07ae 100644
--- a/php-horde-Horde-Secret.spec
+++ b/php-horde-Horde-Secret.spec
@@ -1,5 +1,12 @@
-%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
-%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+# spec file for php-horde-Horde-Secret
+#
+# Copyright (c) 2012-2014 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{!?__pear: %global __pear %{_bindir}/pear}
%global pear_name Horde_Secret
%global pear_channel pear.horde.org
@@ -29,11 +36,11 @@ Requires: php-session
Requires: php-pear(PEAR) >= 1.7.0
Requires: php-channel(%{pear_channel})
Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
-Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Support) >= 2.0.0
-Conflicts: php-pear(%{pear_channel}/Horde_Support) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Support) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Crypt_Blowfish) >= 1.0.0
-Conflicts: php-pear(%{pear_channel}/Horde_Crypt_Blowfish) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Crypt_Blowfish) < 2.0.0
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
@@ -68,13 +75,14 @@ install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
+src=$(pwd)/%{pear_name}-%{version}
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
%if 0%{?rhel} == 5
# Issue with old openssl version
rm -f Unit/SecretTest.php
%endif
phpunit\
- -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
+ --include-path=$src/lib \
-d date.timezone=UTC \
.