summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-19 22:13:47 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-19 22:13:47 +0100
commitd923a95d22293cb99d65d6b470288a8c8f2934b8 (patch)
tree7228fa7a5f110574c8f2592bdc94ea8310a1ad11
parentdb664a6a9afabf5f84652256d673d7bb6dd73ef0 (diff)
php-horde-Horde-Secret 2.0.2
-rw-r--r--Horde_Secret-test.patch35
-rw-r--r--php-horde-Horde-Secret.spec31
2 files changed, 15 insertions, 51 deletions
diff --git a/Horde_Secret-test.patch b/Horde_Secret-test.patch
deleted file mode 100644
index 2455e43..0000000
--- a/Horde_Secret-test.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff -up Horde_Secret-2.0.0/test/Horde/Secret/Autoload.php.old Horde_Secret-2.0.0/test/Horde/Secret/Autoload.php
---- Horde_Secret-2.0.0/test/Horde/Secret/Autoload.php.old 2012-11-07 16:11:54.000000000 +0100
-+++ Horde_Secret-2.0.0/test/Horde/Secret/Autoload.php 2012-11-07 16:12:04.000000000 +0100
-@@ -15,8 +15,8 @@
- require_once 'Horde/Test/Autoload.php';
-
- /** Catch strict standards */
--error_reporting(E_ALL | E_STRICT);
-+error_reporting(E_ALL & ~E_STRICT);
-
- /** Needed for PEAR_Error. */
- require_once 'PEAR.php';
--require_once __DIR__ . '/Stub/Message.php';
-\ Pas de fin de ligne à la fin du fichier
-+require_once __DIR__ . '/Stub/Message.php';
-diff -up Horde_Secret-2.0.0/test/Horde/Secret/Unit/SecretTest.php.old Horde_Secret-2.0.0/test/Horde/Secret/Unit/SecretTest.php
---- Horde_Secret-2.0.0/test/Horde/Secret/Unit/SecretTest.php.old 2012-11-07 16:34:24.000000000 +0100
-+++ Horde_Secret-2.0.0/test/Horde/Secret/Unit/SecretTest.php 2012-11-07 16:34:37.000000000 +0100
-@@ -87,9 +87,6 @@ class Horde_Secret_Unit_SecretTest exten
- $secret->read(new Horde_Secret_Stub_Message(), "\x01");
- }
-
-- /**
-- * @expectedException Horde_Secret_Exception
-- */
- public function testLongKeyException()
- {
- $secret = new Horde_Secret();
-@@ -107,4 +104,4 @@ class Horde_Secret_Unit_SecretTest exten
- $secret = new Horde_Secret();
- $this->assertEquals('', $secret->write('', "\x01"));
- }
--}
-\ Pas de fin de ligne à la fin du fichier
-+}
diff --git a/php-horde-Horde-Secret.spec b/php-horde-Horde-Secret.spec
index f344288..6730dd3 100644
--- a/php-horde-Horde-Secret.spec
+++ b/php-horde-Horde-Secret.spec
@@ -4,8 +4,8 @@
%global pear_channel pear.horde.org
Name: php-horde-Horde-Secret
-Version: 2.0.0
-Release: 2%{?dist}
+Version: 2.0.2
+Release: 1%{?dist}
Summary: Secret Encryption API
Group: Development/Libraries
@@ -13,16 +13,13 @@ License: LGPLv2+
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-# http://bugs.horde.org/ticket/11667
-Patch0: %{pear_name}-test.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-pear(PEAR) >= 1.7.0
BuildRequires: php-channel(%{pear_channel})
# To run unit tests
BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.0.0
-BuildRequires: php-pear(Crypt_Blowfish) >= 1.0.1
+BuildRequires: php-pear(%{pear_channel}/Horde_Crypt_Blowfish) >= 1.0.0
Requires(post): %{__pear}
Requires(postun): %{__pear}
@@ -30,12 +27,13 @@ Requires: php(language) >= 5.3.0
Requires: php-hash
Requires: php-session
Requires: php-pear(PEAR) >= 1.7.0
-Requires: php-pear(Crypt_Blowfish) >= 1.0.1
Requires: php-channel(%{pear_channel})
Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Support) >= 2.0.0
Conflicts: php-pear(%{pear_channel}/Horde_Support) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Crypt_Blowfish) >= 1.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Crypt_Blowfish) >= 2.0.0
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
@@ -46,16 +44,10 @@ shared key.
%prep
-%setup -q -c -T
-tar xif %{SOURCE0}
+%setup -q -c
cd %{pear_name}-%{version}
-%patch0 -p1 -b .11667
-
-# clear md5sum for patched files
-sed -e '/Autoload.php/s/md5sum.*name/name/' \
- -e '/SecretTest.php/s/md5sum.*name/name/' \
- ../package.xml >%{name}.xml
+mv ../package.xml %{name}.xml
%build
@@ -77,7 +69,10 @@ install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-phpunit -d date.timezone=UTC AllTests.php
+phpunit\
+ -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
+ -d date.timezone=UTC \
+ .
%post
@@ -101,6 +96,10 @@ fi
%changelog
+* Mon Nov 19 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.2-1
+- Update to 2.0.2 for remi repo
+- switch from Crypt_Blowfish to Horde_Crypt_Blowfish
+
* Wed Nov 7 2012 Remi Collet <remi@fedoraproject.org> - 2.0.0-2
- add patch for broken unit test
http://bugs.horde.org/ticket/11667