summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Rpc.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-04 13:15:39 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-04 13:15:39 +0100
commitfb75e970ab04aaae95d46c343ce2c72365658ca1 (patch)
treef3774c8f8930ffe03370ecc0c197791b152f835b /php-horde-Horde-Rpc.spec
php-horde-Horde-Rpc: new package
Diffstat (limited to 'php-horde-Horde-Rpc.spec')
-rw-r--r--php-horde-Horde-Rpc.spec134
1 files changed, 134 insertions, 0 deletions
diff --git a/php-horde-Horde-Rpc.spec b/php-horde-Horde-Rpc.spec
new file mode 100644
index 0000000..1bdcaf0
--- /dev/null
+++ b/php-horde-Horde-Rpc.spec
@@ -0,0 +1,134 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Horde_Rpc
+%global pear_channel pear.horde.org
+
+Name: php-horde-Horde-Rpc
+Version: 2.0.0
+Release: 1%{?dist}
+Summary: Horde RPC API
+
+Group: Development/Libraries
+License: LGPL-2.1
+URL: http://pear.horde.org
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+# /usr/lib/rpm/find-lang.sh from fedora 16
+Source1: find-lang.sh
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: gettext
+BuildRequires: php-pear
+BuildRequires: php-channel(%{pear_channel})
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php(language) >= 5.3.0
+Requires: php-ctype
+Requires: php-date
+Requires: php-mbstring
+Requires: php-pcre
+Requires: php-session
+Requires: php-soap
+Requires: php-spl
+Requires: php-xmlrpc
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Core) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Core) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Perms) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Perms) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Serialize) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Serialize) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Support) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Support) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Translation) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Translation) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Util) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Xml_Element) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Xml_Element) >= 3.0.0
+# Optionnal: Horde_ActiveSync, Horde_Http, Horde_Lock, Horde_SyncMl</name>
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+%description
+A common abstracted interface to various remote methods of accessing Horde
+functionality.
+
+
+%prep
+%setup -q -c -T
+tar xif %{SOURCE0}
+
+cd %{pear_name}-%{version}
+
+# Don't install .po and .pot files
+# Remove checksum for .mo, as we regenerate them
+sed -e '/%{pear_name}.po/d' \
+ -e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \
+ ../package.xml >%{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+
+# Regenerate the locales
+for po in $(find locale -name \*.po)
+do
+ msgfmt $po -o $(dirname $po)/$(basename $po .po).mo
+done
+
+
+%install
+cd %{pear_name}-%{version}
+rm -rf %{buildroot}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+%if 0%{?fedora} > 13
+%find_lang %{pear_name}
+%else
+sh %{SOURCE1} %{buildroot} %{pear_name}
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files -f %{pear_name}-%{version}/%{pear_name}.lang
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/Rpc
+%{pear_phpdir}/Horde/Rpc.php
+%{pear_testdir}/%{pear_name}
+# own locales (non standard) directories, .mo own by find_lang
+%dir %{pear_datadir}/%{pear_name}
+%dir %{pear_datadir}/%{pear_name}/locale
+%dir %{pear_datadir}/%{pear_name}/locale/*
+%dir %{pear_datadir}/%{pear_name}/locale/*/LC_MESSAGES
+
+
+%changelog
+* Sun Nov 4 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.0-1
+- Initial package