summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-horde-Horde-Rdo.spec8
1 files changed, 4 insertions, 4 deletions
diff --git a/php-horde-Horde-Rdo.spec b/php-horde-Horde-Rdo.spec
index b1e83f5..bf6485d 100644
--- a/php-horde-Horde-Rdo.spec
+++ b/php-horde-Horde-Rdo.spec
@@ -6,8 +6,7 @@
#
# Please, preserve the changelog entries
#
-%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
-%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%{!?__pear: %global __pear %{_bindir}/pear}
%global pear_name Horde_Rdo
%global pear_channel pear.horde.org
@@ -75,12 +74,13 @@ install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
-cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
%if 0%{?rhel} == 5
: test skipped, issue with sqlite, need investigation
%else
+src=$(pwd)/%{pear_name}-%{version}
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
phpunit\
- -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
+ --include-path=$src/lib \
-d date.timezone=UTC \
.
%endif