summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-05-13 07:30:41 +0200
committerRemi Collet <remi@remirepo.net>2019-05-13 07:30:41 +0200
commit7882c7a3db3bdf4831df2e84c0e4b695ee948815 (patch)
tree3c6d8cd9cebb9d20edc5fb17b8b61f9ae98b1da8
parenta2fedd56389f105a2f980cfb46854117a95faa28 (diff)
- update to 2.1.8HEADmaster
- use range dependencies
-rw-r--r--.gitignore8
-rw-r--r--php-horde-Horde-Perms.spec39
2 files changed, 37 insertions, 10 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-horde-Horde-Perms.spec b/php-horde-Horde-Perms.spec
index 1f9380d..eb49a01 100644
--- a/php-horde-Horde-Perms.spec
+++ b/php-horde-Horde-Perms.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-horde-Horde-Perms
#
-# Copyright (c) 2012-2017 Nick Bebout, Remi Collet
+# Copyright (c) 2012-2019 Nick Bebout, Remi Collet
#
# License: MIT
# https://fedoraproject.org/wiki/Licensing:MIT#Modern_Style_with_sublicense
@@ -12,24 +12,27 @@
%global pear_channel pear.horde.org
Name: php-horde-Horde-Perms
-Version: 2.1.7
+Version: 2.1.8
Release: 1%{?dist}
Summary: Horde Permissions System
-Group: Development/Libraries
License: LGPLv2
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
BuildRequires: php(language) >= 5.3.0
BuildRequires: php-pear(PEAR) >= 1.7.0
BuildRequires: php-channel(%{pear_channel})
BuildRequires: gettext
# To run unit tests
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-pear(%{pear_channel}/Horde_Test) >= 2.1.0 with php-pear(%{pear_channel}/Horde_Test) < 3)
+BuildRequires: (php-pear(%{pear_channel}/Horde_Group) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Group) < 3)
+%else
BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
BuildRequires: php-pear(%{pear_channel}/Horde_Group) >= 2.0.0
+%endif
Requires(post): %{__pear}
Requires(postun): %{__pear}
@@ -37,6 +40,15 @@ Requires: php(language) >= 5.3.0
Requires: php-spl
Requires: php-pear(PEAR) >= 1.7.0
Requires: php-channel(%{pear_channel})
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-pear(%{pear_channel}/Horde_Db) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Db) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Exception) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Group) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Group) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Util) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Util) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Translation) >= 2.2.0 with php-pear(%{pear_channel}/Horde_Translation) < 3)
+# Optional
+Recommends: (php-pear(%{pear_channel}/Horde_Tree) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Tree) < 3)
+%else
Requires: php-pear(%{pear_channel}/Horde_Db) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Db) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
@@ -50,6 +62,7 @@ Requires: php-pear(%{pear_channel}/Horde_Translation) < 3.0.0
# Optional
Requires: php-pear(%{pear_channel}/Horde_Tree) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Tree) < 3.0.0
+%endif
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
Provides: php-composer(horde/horde-perms) = %{version}
@@ -103,11 +116,14 @@ done | tee ../%{pear_name}.lang
%check
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-%{_bindir}/phpunit --verbose .
-if which php70; then
- php70 %{_bindir}/phpunit --verbose .
-fi
+ret=0
+for cmd in php php71 php72 php73; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --bootstrap bootstrap.php --verbose . || ret=1
+ fi
+done
+exit $ret
%post
@@ -122,18 +138,21 @@ fi
%files -f %{pear_name}.lang
-%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/Perms
%{pear_phpdir}/Horde/Perms.php
-%{pear_testdir}/%{pear_name}
+%doc %{pear_testdir}/%{pear_name}
%dir %{pear_datadir}/%{pear_name}
%dir %{pear_datadir}/%{pear_name}/locale
%{pear_datadir}/%{pear_name}/migration
%changelog
+* Mon May 13 2019 Remi Collet <remi@remirepo.net> - 2.1.8-1
+- update to 2.1.8
+- use range dependencies
+
* Wed Mar 09 2016 Remi Collet <remi@fedoraproject.org> - 2.1.7-1
- Update to 2.1.7 (no change)
- PHP 7 compatible version