summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-11-04 08:18:22 +0100
committerRemi Collet <remi@remirepo.net>2019-11-04 08:18:22 +0100
commitcbc12a96d90dc5fbcdb44ec31088d9c0d68cfb39 (patch)
tree141751c1b8404abb0a7beac4637a4a209f7d6ad2
parentc002cdfa2010ab32753bc5691f4afd6992b15055 (diff)
-rw-r--r--1.patch63
-rw-r--r--php-horde-Horde-Pdf.spec17
2 files changed, 8 insertions, 72 deletions
diff --git a/1.patch b/1.patch
deleted file mode 100644
index 3d46f22..0000000
--- a/1.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From b7f1722e43c8d58f66204865952e1cd70e85ddb7 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 17 Oct 2019 15:34:44 +0200
-Subject: [PATCH 1/2] fix get_magic_quotes_runtime() is deprecated
-
----
- lib/Horde/Pdf/Writer.php | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/lib/Horde/Pdf/Writer.php b/lib/Horde/Pdf/Writer.php
-index 8d67c4b..cdf82db 100644
---- a/lib/Horde/Pdf/Writer.php
-+++ b/lib/Horde/Pdf/Writer.php
-@@ -2313,7 +2313,7 @@ public function image($file, $x, $y, $width = 0, $height = 0, $type = '',
- $type = substr($file, $pos + 1);
- }
-
-- $mqr = get_magic_quotes_runtime();
-+ $mqr = function_exists("get_magic_quotes_runtime") ? @get_magic_quotes_runtime() : 0;
- if ($mqr) { set_magic_quotes_runtime(0); }
-
- $type = Horde_String::lower($type);
-@@ -2705,7 +2705,7 @@ protected function _putFonts()
- $this->_out('endobj');
- }
-
-- $mqr = get_magic_quotes_runtime();
-+ $mqr = function_exists("get_magic_quotes_runtime") ? @get_magic_quotes_runtime() : 0;
- if ($mqr) { set_magic_quotes_runtime(0); }
-
- foreach ($this->_font_files as $file => $info) {
-
-From fe2c5fb7a6dee24e8e34b793a59da0ac0bbaba67 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 17 Oct 2019 15:35:08 +0200
-Subject: [PATCH 2/2] fix access syntax with curly braces is deprecated
-
----
- lib/Horde/Pdf/Writer.php | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/lib/Horde/Pdf/Writer.php b/lib/Horde/Pdf/Writer.php
-index cdf82db..6b20a4a 100644
---- a/lib/Horde/Pdf/Writer.php
-+++ b/lib/Horde/Pdf/Writer.php
-@@ -1198,7 +1198,7 @@ public function getStringWidth($text, $pt = false)
- $width = 0;
- $length = strlen($text);
- for ($i = 0; $i < $length; $i++) {
-- $width += $this->_current_font['cw'][$text{$i}];
-+ $width += $this->_current_font['cw'][$text[$i]];
- }
-
- /* Adjust for word spacing. */
-@@ -2138,7 +2138,7 @@ public function write($height, $text, $link = '')
- $nl = 1;
- while ($i < $nb) {
- // Get next character.
-- $c = $s{$i};
-+ $c = $s[$i];
- if ($c == "\n") {
- // Explicit line break.
- $this->cell($width, $height, substr($s, $j, $i - $j), 0, 2, '', 0, $link);
diff --git a/php-horde-Horde-Pdf.spec b/php-horde-Horde-Pdf.spec
index f4d297a..7627271 100644
--- a/php-horde-Horde-Pdf.spec
+++ b/php-horde-Horde-Pdf.spec
@@ -12,16 +12,14 @@
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: php-horde-Horde-Pdf
-Version: 2.0.7
-Release: 8%{?dist}
+Version: 2.0.8
+Release: 1%{?dist}
Summary: Horde PDF library
License: LGPLv2
URL: http://%{pear_channel}
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-Patch0: https://patch-diff.githubusercontent.com/raw/horde/Pdf/pull/1.patch
-
BuildArch: noarch
BuildRequires: php(language) >= 5.3.0
BuildRequires: php-pear(PEAR) >= 1.7.0
@@ -67,10 +65,7 @@ PDF generation using only PHP, without requiring any external libraries.
%prep
%setup -q -c
cd %{pear_name}-%{version}
-%patch0 -p1 -b .pr1
-
-sed -e '/Writer.php/s/md5sum=.*name=/name=/' \
- ../package.xml >%{name}.xml
+mv ../package.xml %{name}.xml
%build
@@ -97,7 +92,7 @@ cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
ret=0
for cmd in php php71 php72 php73 php74; do
if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose . || ret=1
+ $cmd %{_bindir}/phpunit --bootstrap bootstrap.php --verbose . || ret=1
fi
done
exit $ret
@@ -127,6 +122,10 @@ fi
%changelog
+* Mon Nov 4 2019 Remi Collet <remi@remirepo.net> - 2.0.8-1
+- update to 2.0.8
+- drop patch merged upstream
+
* Thu Oct 17 2019 Remi Collet <remi@remirepo.net> - 2.0.7-8
- add patch for PHP 7.4 from
https://github.com/horde/Pdf/pull/1