summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-01-18 08:32:54 +0100
committerRemi Collet <fedora@famillecollet.com>2014-01-18 08:32:54 +0100
commit6130e7d1ad24abdeaae1b4366dd97348670b22e4 (patch)
tree5addfe8e6c9c6301d92f21dac378eeac907ec590
php-horde-Horde-Pack: 1.0.0 - New package
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-Pack.spec123
2 files changed, 127 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-Pack.spec b/php-horde-Horde-Pack.spec
new file mode 100644
index 0000000..d29f49d
--- /dev/null
+++ b/php-horde-Horde-Pack.spec
@@ -0,0 +1,123 @@
+# spec file for php-horde-Horde-Pack
+#
+# Copyright (c) 2014 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %global __pear %{_bindir}/pear}
+%global pear_name Horde_Pack
+%global pear_channel pear.horde.org
+
+Name: php-horde-Horde-Pack
+Version: 1.0.0
+Release: 1%{?dist}
+Summary: Horde Pack Utility
+
+Group: Development/Libraries
+License: LGPLv2
+URL: http://%{pear_channel}
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 5.3.0
+BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-channel(%{pear_channel})
+# To run unit tests
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Compress_Fast) >= 1.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+BuildRequires: php-json
+BuildRequires: php-pecl(igbinary)
+# msgpack not available on all arch
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+# From package.xml, required
+Requires: php(language) >= 5.3.0
+Requires: php-pear(PEAR) >= 1.7.0
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Compress_Fast) >= 1.0.0
+Requires: php-pear(%{pear_channel}/Horde_Compress_Fast) < 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) < 3.0.0
+# From package.xml, optional: json, msgpack, igbinary
+# From phpcompatinfo report for version 1.0.0
+Requires: php-spl
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+%description
+A replacement for serialize()/json_encode() that will automatically use the
+most efficient serialization available based on the input.
+
+The serialization extensions you may want to install are:
+- php-json
+- php-pecl-igbinary
+- php-pecl-msgpack
+
+
+%prep
+%setup -q -c
+
+cd %{pear_name}-%{version}
+mv ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%check
+src=$(pwd)/%{pear_name}-%{version}
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+phpunit \
+ --include-path=$src/lib \
+ -d date.timezone=UTC \
+ .
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/Pack
+%{pear_phpdir}/Horde/Pack.php
+%{pear_testdir}/%{pear_name}
+
+
+%changelog
+* Sat Jan 18 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- initial package \ No newline at end of file