summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-04-05 12:37:40 +0200
committerRemi Collet <fedora@famillecollet.com>2013-04-05 12:37:40 +0200
commitd74ad24ac5cde1bfe63baf8ed279c50af5cf4bf2 (patch)
treed9d72dfabe31becaf42cf164de514c527a7a8ea6
php-horde-Horde-Oauth: new package
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-Oauth.spec92
2 files changed, 96 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-Oauth.spec b/php-horde-Horde-Oauth.spec
new file mode 100644
index 0000000..589c441
--- /dev/null
+++ b/php-horde-Horde-Oauth.spec
@@ -0,0 +1,92 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Horde_Oauth
+%global pear_channel pear.horde.org
+
+Name: php-horde-Horde-Oauth
+Version: 2.0.1
+Release: 1%{?dist}
+Summary: Horde OAuth client/server
+
+Group: Development/Libraries
+License: BSD
+URL: http://%{pear_channel}
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 5.3.0
+BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-channel(%{pear_channel})
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php(language) >= 5.3.0
+Requires: php-date
+Requires: php-hash
+Requires: php-openssl
+Requires: php-spl
+Requires: php-pear(PEAR) >= 1.7.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Http) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Http) >= 3.0.0
+Requires: php-channel(%{pear_channel})
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+
+%description
+An OAuth consumer (http://oauth.net) and OAuth infrastructure, and in the
+future will provide an OAuth server.
+
+%prep
+%setup -q -c
+
+cd %{pear_name}-%{version}
+mv ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/Oauth
+
+
+%changelog
+* Fri Apr 5 2013 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
+- initial package