summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-03 09:03:53 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-03 09:03:53 +0100
commit60640fe5ea8f7a062cc4f604c45df556bc0d7f60 (patch)
tree814d29b8622a8bf30fd206dbe44261881135a74e
parent4d0d9c6bf4822e9ea811878faa5c4b7fb1fe1d46 (diff)
php-horde-Horde-Notification: 2.0.0
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-Notification.spec79
2 files changed, 43 insertions, 40 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-Notification.spec b/php-horde-Horde-Notification.spec
index d761866..9c1aab0 100644
--- a/php-horde-Horde-Notification.spec
+++ b/php-horde-Horde-Notification.spec
@@ -1,42 +1,48 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
-%global pear_name Horde_Notification
+%global pear_name Horde_Notification
+%global pear_channel pear.horde.org
Name: php-horde-Horde-Notification
-Version: 1.0.1
+Version: 2.0.0
Release: 1%{?dist}
Summary: Horde Notification System
Group: Development/Libraries
License: LGPLv2
URL: http://pear.horde.org
-Source0: http://pear.horde.org/get/%{pear_name}-%{version}.tgz
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
-
-BuildRequires: php-pear(PEAR) >= 1.7.0
-BuildRequires: php-channel(pear.horde.org)
+BuildRequires: php-pear
+BuildRequires: php-channel(%{pear_channel})
+# To run unit tests
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.0.0
Requires(post): %{__pear}
Requires(postun): %{__pear}
-Requires: php-pear(pear.horde.org/Horde_Exception) >= 1.0.0
-Requires: php-pear(pear.horde.org/Horde_Exception) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Util) >= 1.0.0
-Requires: php-pear(pear.horde.org/Horde_Util) < 2.0.0
-Requires: php-pear(PEAR) >= 1.7.0
-Requires: php-channel(pear.horde.org)
+Requires: php(language) >= 5.3.0
+Requires: php-gettext
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Util) >= 3.0.0
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
-Provides: php-pear(pear.horde.org/Horde_Notification) = %{version}
%description
A library implementing a subject-observer pattern for raising and showing
messages of different types and to different listeners.
%prep
-%setup -q -c
-[ -f package2.xml ] || mv package.xml package2.xml
-mv package2.xml %{pear_name}-%{version}/%{name}.xml
+%setup -q -c -T
+tar xif %{SOURCE0}
cd %{pear_name}-%{version}
+cp ../package.xml %{name}.xml
%build
@@ -46,14 +52,20 @@ cd %{pear_name}-%{version}
%install
cd %{pear_name}-%{version}
-%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%check
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+phpunit -d date.timezone=UTC AllTests.php
+
%post
%{__pear} install --nodeps --soft --force --register-only \
@@ -62,35 +74,22 @@ install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
%postun
if [ $1 -eq 0 ] ; then
%{__pear} uninstall --nodeps --ignore-errors --register-only \
- pear.horde.org/%{pear_name} >/dev/null || :
+ %{pear_channel}/%{pear_name} >/dev/null || :
fi
%files
+%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
-
-
%{pear_xmldir}/%{name}.xml
-# Expand this as needed to avoid owning dirs owned by our dependencies
-# and to avoid unowned dirs
-%{pear_phpdir}/Horde/Notification/Event/Status.php
-%{pear_phpdir}/Horde/Notification/Handler/Decorator/Alarm.php
-%{pear_phpdir}/Horde/Notification/Handler/Decorator/Base.php
-%{pear_phpdir}/Horde/Notification/Handler/Decorator/Log.php
-%{pear_phpdir}/Horde/Notification/Listener/Audio.php
-%{pear_phpdir}/Horde/Notification/Listener/Status.php
-%{pear_phpdir}/Horde/Notification/Storage/Interface.php
-%{pear_phpdir}/Horde/Notification/Storage/Object.php
-%{pear_phpdir}/Horde/Notification/Storage/Session.php
-%{pear_phpdir}/Horde/Notification/Event.php
-%{pear_phpdir}/Horde/Notification/Exception.php
-%{pear_phpdir}/Horde/Notification/Handler.php
-%{pear_phpdir}/Horde/Notification/Listener.php
+%{pear_phpdir}/Horde/Notification
%{pear_phpdir}/Horde/Notification.php
-
-%{pear_testdir}/Horde_Notification
+%{pear_testdir}/%{pear_name}
%changelog
+* Sat Nov 3 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.0-1
+- Update to 2.0.0 for remi repo
+
* Thu Jun 21 2012 Nick Bebout <nb@fedoraproject.org> - 1.0.1-1
- Initial package