summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Mime-Viewer.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-04 09:56:27 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-04 09:56:27 +0100
commitaafca72468931aad1c4e247688924e38d6d28732 (patch)
tree9175d142293e250f7f0644c319133ef52a877eb2 /php-horde-Horde-Mime-Viewer.spec
php-horde-Horde-Mime-Viewer: new package
Diffstat (limited to 'php-horde-Horde-Mime-Viewer.spec')
-rw-r--r--php-horde-Horde-Mime-Viewer.spec139
1 files changed, 139 insertions, 0 deletions
diff --git a/php-horde-Horde-Mime-Viewer.spec b/php-horde-Horde-Mime-Viewer.spec
new file mode 100644
index 0000000..9c05ebc
--- /dev/null
+++ b/php-horde-Horde-Mime-Viewer.spec
@@ -0,0 +1,139 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Horde_Mime_Viewer
+%global pear_channel pear.horde.org
+
+Name: php-pear.horde.org-Horde-Mime-Viewer
+Version: 2.0.0
+Release: 1%{?dist}
+Summary: Horde MIME Viewer Library
+
+Group: Development/Libraries
+# Horde_Mime_Viewer extension is LGPLv2, syntaxhighlighter is LGPLv3 or MIT
+License: LGPLv2 and LGPLv3 or MIT
+URL: http://pear.horde.org
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+# /usr/lib/rpm/find-lang.sh from fedora 16
+Source1: find-lang.sh
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php-pear
+BuildRequires: php-channel(%{pear_channel})
+BuildRequires: gettext
+BuildRequires: php-pear(%{pear_channel}/Horde_Role) >= 1.0.0
+# no test for now (all skipped)
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php(language) >= 5.3.0
+Requires: php-date
+Requires: php-dom
+Requires: php-libxml
+Requires: php-pcre
+Requires: php-spl
+Requires: php-xsl
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Role) >= 1.0.0
+Requires: php-pear(%{pear_channel}/Horde_Browser) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Browser) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Compress) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Compress) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Mime) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Mime) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Text_Filter) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Text_Filter) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Text_Flowed) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Text_Flowed) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Util) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Translation) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Translation) >= 3.0.0
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+
+%description
+Provides rendering drivers for MIME data.
+
+%prep
+%setup -q -c -T
+tar xif %{SOURCE0}
+
+cd %{pear_name}-%{version}
+
+# Don't install .po and .pot files
+# Remove checksum for .mo, as we regenerate them
+sed -e '/%{pear_name}.po/d' \
+ -e '/LICENSE/s/role="horde"/role="doc"/' \
+ -e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \
+ ../package.xml >%{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+
+# Regenerate the locales
+for po in $(find locale -name \*.po)
+do
+ msgfmt $po -o $(dirname $po)/$(basename $po .po).mo
+done
+
+
+%install
+cd %{pear_name}-%{version}
+rm -rf %{buildroot}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+%if 0%{?fedora} > 13
+%find_lang %{pear_name}
+%else
+sh %{SOURCE1} %{buildroot} %{pear_name}
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files -f %{pear_name}-%{version}/%{pear_name}.lang
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/Mime/Viewer
+%{pear_phpdir}/Horde/Mime/Viewer.php
+%{pear_testdir}/%{pear_name}
+# own locales (non standard) directories, .mo own by find_lang
+%dir %{pear_datadir}/%{pear_name}
+%dir %{pear_datadir}/%{pear_name}/locale
+%dir %{pear_datadir}/%{pear_name}/locale/*
+%dir %{pear_datadir}/%{pear_name}/locale/*/LC_MESSAGES
+# Web files
+%dir %{pear_hordedir}/js
+%{pear_hordedir}/js/syntaxhighlighter
+
+
+%changelog
+* Sun Nov 4 2012 Remi Collet <RPMS@FamilleCollet.com> - 1.0.0-1
+- Initial package
+