summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Mapi.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-horde-Horde-Mapi.spec')
-rw-r--r--php-horde-Horde-Mapi.spec36
1 files changed, 22 insertions, 14 deletions
diff --git a/php-horde-Horde-Mapi.spec b/php-horde-Horde-Mapi.spec
index 70c49a4..ac2cb5e 100644
--- a/php-horde-Horde-Mapi.spec
+++ b/php-horde-Horde-Mapi.spec
@@ -12,7 +12,7 @@
Name: php-horde-Horde-Mapi
Version: 1.0.8
-Release: 2%{?dist}
+Release: 5%{?dist}
Summary: MAPI utility library
Group: Development/Libraries
@@ -20,7 +20,12 @@ License: LGPLv2
URL: http://%{pear_channel}
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+Patch0: 0001-fix-for-BigEndian.patch
+
+# remirepo:3
+# For test build on all available arch
+#global debug_package %{nil}
+#global __debug_install_post /bin/true
BuildArch: noarch
BuildRequires: php(language) >= 5.3.0
BuildRequires: php-pear(PEAR) >= 1.7.0
@@ -67,7 +72,9 @@ data.
%setup -q -c
cd %{pear_name}-%{version}
-mv ../package.xml %{name}.xml
+%patch0 -p1 -b .temp
+
+sed -e 's/md5sum="[^"]*"//' ../package.xml >%{name}.xml
%build
@@ -76,7 +83,6 @@ cd %{pear_name}-%{version}
%install
-rm -rf %{buildroot}
cd %{pear_name}-%{version}
%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
@@ -90,15 +96,14 @@ install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-%{_bindir}/phpunit .
-
-if which php70; then
- php70 %{_bindir}/phpunit .
-fi
-
-%clean
-rm -rf %{buildroot}
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit . || ret=1
+ fi
+done
+exit $ret
%post
@@ -113,15 +118,18 @@ fi
%files
-%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/Mapi
%{pear_phpdir}/Horde/Mapi.php
-%{pear_testdir}/%{pear_name}
+%doc %{pear_testdir}/%{pear_name}
%changelog
+* Mon Nov 13 2017 Remi Collet <remi@fedoraproject.org> - 1.0.8-5
+- fix erratic FTBFS from Koschei, add fix for big endian from
+ https://github.com/horde/Mapi/pull/1
+
* Mon Dec 5 2016 Remi Collet <remi@fedoraproject.org> - 1.0.8-2
- switch to php-pear(Math_BigInteger) in F26+