summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-06-23 07:55:22 +0200
committerRemi Collet <remi@remirepo.net>2017-06-23 07:55:22 +0200
commitb78ee5af9b05b46f6c5667fa277341adf114cc5f (patch)
tree0ea53982dd2e8d0e476fcfbb3c5110349a8dd5ce
parentdf2f509dc9bf3f3e269a1e2b91df5f4dc15114cf (diff)
v2.6.4
-rw-r--r--.gitignore7
-rw-r--r--php-horde-Horde-Mail.spec34
2 files changed, 31 insertions, 10 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-horde-Horde-Mail.spec b/php-horde-Horde-Mail.spec
index ee4e7c6..d6073a1 100644
--- a/php-horde-Horde-Mail.spec
+++ b/php-horde-Horde-Mail.spec
@@ -15,7 +15,7 @@
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
Name: php-horde-Horde-Mail
-Version: 2.6.3
+Version: 2.6.4
Release: 1%{?dist}
Summary: Horde Mail Library
@@ -24,8 +24,8 @@ License: BSD
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
+BuildRequires: gettext
BuildRequires: php(language) >= 5.3.0
BuildRequires: php-pear(PEAR) >= 1.7.0
BuildRequires: php-channel(%{pear_channel})
@@ -107,15 +107,24 @@ rm -rf %{buildroot}%{pear_metadir}/.??*
mkdir -p %{buildroot}%{pear_xmldir}
install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+for loc in locale/{??,??_??}
+do
+ lang=$(basename $loc)
+ test -d %{buildroot}%{pear_datadir}/%{pear_name}/$loc \
+ && echo "%%lang(${lang%_*}) %{pear_datadir}/%{pear_name}/$loc"
+done | tee ../%{pear_name}.lang
+
%check
%if %{with_tests}
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-%{_bindir}/phpunit .
-
-if which php70; then
- php70 %{_bindir}/phpunit .
-fi
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose .
+ fi
+done
+exit $ret
%else
: Test disabled, missing '--with tests' option.
%endif
@@ -132,15 +141,20 @@ if [ $1 -eq 0 ] ; then
fi
-%files
-%defattr(-,root,root,-)
+%files -f %{pear_name}.lang
%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/Mail
-%{pear_testdir}/%{pear_name}
+%doc %{pear_testdir}/%{pear_name}
+%dir %{pear_datadir}/%{pear_name}
+%dir %{pear_datadir}/%{pear_name}/locale
%changelog
+* Fri Jun 23 2017 Remi Collet <remi@remirepo.net> - 2.6.4-1
+- Update to 2.6.4
+- add locales
+
* Tue Feb 02 2016 Remi Collet <remi@fedoraproject.org> - 2.6.3-1
- Update to 2.6.3
- PHP 7 compatible version