summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-07-08 20:54:29 +0200
committerRemi Collet <fedora@famillecollet.com>2014-07-08 20:54:29 +0200
commitaed5cb30d7faf253e6c5a7c768151e7d3060489e (patch)
tree956e9e01353623f5e4e2fecbe67351aac3914e0f
php-horde-Horde-Mail-Autoconfig: 1.0.0 - New package
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-Mail-Autoconfig.spec129
2 files changed, 133 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-Mail-Autoconfig.spec b/php-horde-Horde-Mail-Autoconfig.spec
new file mode 100644
index 0000000..f052210
--- /dev/null
+++ b/php-horde-Horde-Mail-Autoconfig.spec
@@ -0,0 +1,129 @@
+# spec file for php-horde-Horde-Mail-Autoconfig
+#
+# Copyright (c) 2014 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{!?__pear: %global __pear %{_bindir}/pear}
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%global pear_name Horde_Mail_Autoconfig
+%global pear_channel pear.horde.org
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+
+Name: php-horde-Horde-Mail-Autoconfig
+Version: 1.0.0
+Release: 1%{?dist}
+Summary: Horde Mail Autoconfiguration
+
+Group: Development/Libraries
+License: LGPLv2
+URL: http://pear.horde.org/
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 5.3.0
+BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-channel(%{pear_channel})
+%if %{with_tests}
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
+%endif
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+# From package.xml
+Requires: php(language) >= 5.3.0
+Requires: php-pear(PEAR) >= 1.7.0
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Http) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Http) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Imap_Client) >= 2.20.1
+Requires: php-pear(%{pear_channel}/Horde_Imap_Client) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Mail) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Mail) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Smtp) >= 1.1.0
+Requires: php-pear(%{pear_channel}/Horde_Smtp) < 2.0.0
+Requires: php-pear(Net_DNS2) >= 1.3.0
+Requires: php-simplexml
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+
+%description
+Attempts to automatically determine configuration options for various
+remote mail services (IMAP/POP3/SMTP).
+
+
+%prep
+%setup -q -c
+
+cd %{pear_name}-%{version}
+mv ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+rm -rf %{buildroot}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%check
+%if %{with_tests}
+src=$(pwd)/%{pear_name}-%{version}
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+
+# ignore this broken test for now
+rm AutoconfigTest.php
+
+phpunit \
+ --include-path=$src/lib \
+ -d date.timezone=UTC \
+ .
+%else
+: Test disabled, missing '--with tests' option.
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/Mail/Autoconfig/
+%{pear_phpdir}/Horde/Mail/Autoconfig.php
+%{pear_testdir}/%{pear_name}
+
+
+%changelog
+* Tue Jul 8 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- Initial package \ No newline at end of file