summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-01-09 14:16:46 +0100
committerRemi Collet <fedora@famillecollet.com>2015-01-09 14:16:46 +0100
commit1e080250aa5d4c319ce2f6a22e8566f097cadaae (patch)
tree322800ea19f05da9cf6da02d0dd10e5155a6e39b
parent3e90c9d2f58938ad1197b26ad1b7a1a78bdc3b2f (diff)
php-horde-Horde-Log: 2.1.1
-rw-r--r--php-horde-Horde-Log.spec34
1 files changed, 24 insertions, 10 deletions
diff --git a/php-horde-Horde-Log.spec b/php-horde-Horde-Log.spec
index 06aa4fa..10193f9 100644
--- a/php-horde-Horde-Log.spec
+++ b/php-horde-Horde-Log.spec
@@ -1,12 +1,24 @@
-%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+# spec file for php-horde-Horde-Scribe
+#
+# Copyright (c) 2012-2015 Nick Bebout, Remi Collet
+#
+# License: MIT
+# https://fedoraproject.org/wiki/Licensing:MIT#Modern_Style_with_sublicense
+#
+# Please, preserve the changelog entries
+#
+%{!?__pear: %global __pear %{_bindir}/pear}
+%global bootstrap 0
%global pear_name Horde_Log
%global pear_channel pear.horde.org
-
-# Can run test because of circular dependency with Horde_Test
+%if %{bootstrap}
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%else
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%endif
Name: php-horde-Horde-Log
-Version: 2.1.0
+Version: 2.1.1
Release: 1%{?dist}
Summary: Horde Logging library
@@ -46,14 +58,14 @@ Requires: php-pear(%{pear_channel}/Horde_Scribe) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Scribe) < 3.0.0
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+Provides: php-composer(horde/horde-log) = %{version}
%description
Horde Logging package with configurable handlers, filters, and formatting.
%prep
-%setup -q -c -T
-tar xif %{SOURCE0}
+%setup -q -c
cd %{pear_name}-%{version}
mv ../package.xml %{name}.xml
@@ -79,10 +91,7 @@ install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
%if %{with_tests}
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-phpunit\
- -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
- -d date.timezone=UTC \
- .
+phpunit .
%else
: Test disabled, missing '--with tests' option.
%endif
@@ -109,6 +118,11 @@ fi
%changelog
+* Fri Jan 09 2015 Remi Collet <remi@fedoraproject.org> - 2.1.1-1
+- Update to 2.1.1
+- add provides php-composer(horde/horde-log)
+- enable test suite
+
* Tue Oct 15 2013 Remi Collet <remi@fedoraproject.org> - 2.1.0-1
- Update to 2.1.0