summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-ListHeaders.spec100
2 files changed, 104 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-ListHeaders.spec b/php-horde-Horde-ListHeaders.spec
new file mode 100644
index 0000000..8a201f0
--- /dev/null
+++ b/php-horde-Horde-ListHeaders.spec
@@ -0,0 +1,100 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Horde_ListHeaders
+%global pear_channel pear.horde.org
+
+Name: php-horde-Horde-ListHeaders
+Version: 1.0.1
+Release: 1%{?dist}
+Summary: Horde List Headers Parsing Library
+
+Group: Development/Libraries
+License: LGPLv2
+URL: http://pear.horde.org
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php-common >= 5.3.0
+BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-channel(%{pear_channel})
+# To run unit tests
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Mail) >= 2.0.0
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php-common >= 5.3.0
+Requires: php-pear(PEAR) >= 1.7.0
+Requires: php-pear(%{pear_channel}/Horde_Mail) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Mail) >= 3.0.0
+Requires: php-channel(%{pear_channel})
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+
+%description
+The Horde_ListHeaders library parses Mailing List Headers as defined in RFC
+2369 & RFC 2919.
+
+
+%prep
+%setup -q -c
+
+cd %{pear_name}-%{version}
+cp ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+rm -rf %{buildroot}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%check
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+phpunit\
+ -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
+ -d date.timezone=UTC \
+ .
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/ListHeaders
+%{pear_phpdir}/Horde/ListHeaders.php
+%{pear_testdir}/%{pear_name}
+
+
+%changelog
+* Sat Jan 12 2013 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
+- Initial package