summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-01-09 15:21:30 +0100
committerRemi Collet <fedora@famillecollet.com>2015-01-09 15:21:30 +0100
commit7953579ee2057f844a73a166d4b77363dae6fd7c (patch)
tree41c8e834590930ba8fef51e2b5980d86511c7a32
parente1bdc5e23815682a423808262db05a0f58dfc5ef (diff)
php-horde-Horde-Kolab-Storage: 2.1.2
-rw-r--r--Horde_Kolab_Storage-upstream.patch94
-rw-r--r--php-horde-Horde-Kolab-Storage.spec23
2 files changed, 10 insertions, 107 deletions
diff --git a/Horde_Kolab_Storage-upstream.patch b/Horde_Kolab_Storage-upstream.patch
deleted file mode 100644
index 76740c3..0000000
--- a/Horde_Kolab_Storage-upstream.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-From f07864e5b4b201999944decc13b629eadb3d4248 Mon Sep 17 00:00:00 2001
-From: Michael M Slusarz <slusarz@horde.org>
-Date: Mon, 10 Nov 2014 23:56:08 -0700
-Subject: [PATCH] Fix tests
-
----
- .../lib/Horde/Kolab/Storage/Object/MimeType.php | 2 +-
- .../test/Horde/Kolab/Storage/Unit/ObjectTest.php | 20 ++++++++------------
- .../test/Horde/Push/Unit/Push/Recipient/MailTest.php | 2 +-
- 3 files changed, 10 insertions(+), 14 deletions(-)
-
-diff --git a/framework/Kolab_Storage/test/Horde/Kolab/Storage/Unit/ObjectTest.php b/framework/Kolab_Storage/test/Horde/Kolab/Storage/Unit/ObjectTest.php
-index 9ca5ebb..3b3381f 100644
---- a/framework/Kolab_Storage/test/Horde/Kolab/Storage/Unit/ObjectTest.php
-+++ b/framework/Kolab_Storage/test/Horde/Kolab/Storage/Unit/ObjectTest.php
-@@ -71,9 +71,8 @@ public function testObjectTypeDeviatesFromFolderType()
- $data = $this->getMock('Horde_Kolab_Storage_Object_Writer');
- $object = new Horde_Kolab_Storage_Object();
- $headers = $this->getMock('Horde_Mime_Headers');
-- $headers->expects($this->once())
-- ->method('getValue')
-- ->with('X-Kolab-Type')
-+ $headers->method('__call')
-+ ->with('getValue', array('X-Kolab-Type'))
- ->will($this->returnValue('application/x-vnd.kolab.note'));
- $this->folder->expects($this->once())
- ->method('getType')
-@@ -100,9 +99,8 @@ public function testMissingKolabPart()
- $data = $this->getMock('Horde_Kolab_Storage_Object_Writer');
- $object = new Horde_Kolab_Storage_Object();
- $headers = $this->getMock('Horde_Mime_Headers');
-- $headers->expects($this->once())
-- ->method('getValue')
-- ->with('X-Kolab-Type')
-+ $headers->method('__call')
-+ ->with('getValue', array('X-Kolab-Type'))
- ->will($this->returnValue('application/x-vnd.kolab.note'));
- $this->folder->expects($this->once())
- ->method('getType')
-@@ -137,9 +135,8 @@ public function testObjectRetainsHeadersIfLoaded()
- $data = $this->getMock('Horde_Kolab_Storage_Object_Writer');
- $object = new Horde_Kolab_Storage_Object();
- $headers = $this->getMock('Horde_Mime_Headers');
-- $headers->expects($this->once())
-- ->method('getValue')
-- ->with('X-Kolab-Type')
-+ $headers->method('__call')
-+ ->with('getValue', array('X-Kolab-Type'))
- ->will($this->returnValue('application/x-vnd.kolab.note'));
- $this->folder->expects($this->once())
- ->method('getType')
-@@ -326,9 +323,8 @@ public function testSerializeUnserializeRetainsErrors()
- $data = $this->getMock('Horde_Kolab_Storage_Object_Writer');
- $object = new Horde_Kolab_Storage_Object();
- $headers = $this->getMock('Horde_Mime_Headers');
-- $headers->expects($this->once())
-- ->method('getValue')
-- ->with('X-Kolab-Type')
-+ $headers->method('__call')
-+ ->with('getValue', array('X-Kolab-Type'))
- ->will($this->returnValue('application/x-vnd.kolab.note'));
- $this->folder->expects($this->once())
- ->method('getType')
-From c6e85ba158ec4b7cc9d2c22f592aaffaee7751de Mon Sep 17 00:00:00 2001
-From: Michael M Slusarz <slusarz@horde.org>
-Date: Thu, 20 Nov 2014 17:09:45 -0700
-Subject: [PATCH] Fix test
-
----
- .../Storage/ComponentTest/Data/Object/Message/ModifiedTest.php | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/framework/Kolab_Storage/test/Horde/Kolab/Storage/ComponentTest/Data/Object/Message/ModifiedTest.php b/framework/Kolab_Storage/test/Horde/Kolab/Storage/ComponentTest/Data/Object/Message/ModifiedTest.php
-index d8b6551..bf00433 100644
---- a/framework/Kolab_Storage/test/Horde/Kolab/Storage/ComponentTest/Data/Object/Message/ModifiedTest.php
-+++ b/framework/Kolab_Storage/test/Horde/Kolab/Storage/ComponentTest/Data/Object/Message/ModifiedTest.php
-@@ -90,14 +90,14 @@ public function testStore()
- User-Agent: Horde::Kolab::Storage v@version@
- MIME-Version: 1.0
- X-Kolab-Type: application/x-vnd.kolab.note
--Content-Type: multipart/mixed; boundary="";
-- name="Kolab Groupware Data"
-+Content-Type: multipart/mixed; name="Kolab Groupware Data";
-+ boundary=""
- Content-Disposition: attachment; filename="Kolab Groupware Data"
-
- This message is in MIME format.
-
- --=_
--Content-Type: text/plain; charset=utf-8; name="Kolab Groupware Information"
-+Content-Type: text/plain; name="Kolab Groupware Information"; charset=utf-8
- Content-Disposition: inline; filename="Kolab Groupware Information"
-
- This is a Kolab Groupware object. To view this object you will need an email
diff --git a/php-horde-Horde-Kolab-Storage.spec b/php-horde-Horde-Kolab-Storage.spec
index f3a07d8..df8e662 100644
--- a/php-horde-Horde-Kolab-Storage.spec
+++ b/php-horde-Horde-Kolab-Storage.spec
@@ -11,8 +11,8 @@
%global pear_channel pear.horde.org
Name: php-horde-Horde-Kolab-Storage
-Version: 2.1.1
-Release: 2%{?dist}
+Version: 2.1.2
+Release: 1%{?dist}
Summary: A package for handling Kolab data stored on an IMAP server
Group: Development/Libraries
@@ -20,8 +20,6 @@ License: LGPLv2
URL: http://%{pear_channel}
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-Patch0: %{pear_name}-upstream.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: gettext
@@ -52,7 +50,7 @@ Requires: php-pear(%{pear_channel}/Horde_Kolab_Format) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Kolab_Format) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Mime) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Mime) < 3.0.0
-Requires: php-pear(%{pear_channel}/Horde_Translation) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Translation) >= 2.2.0
Requires: php-pear(%{pear_channel}/Horde_Translation) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Support) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Support) < 3.0.0
@@ -68,6 +66,7 @@ Requires: php-pear(HTTP_Request)
Requires: php-pear(Net_IMAP) >= 1.1.0
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+Provides: php-composer(horde/horde-kolab-storage) = %{version}
%description
@@ -79,14 +78,11 @@ to deal with this type of data storage effectively.
%setup -q -c
cd %{pear_name}-%{version}
-%patch0 -p3 -b .upstream
-
# Don't install .po and .pot files
# Remove checksum for .mo, as we regenerate them
sed -e '/%{pear_name}.po/d' \
-e '/Horde_Other.po/d' \
-e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \
- -e '/test/s/md5sum=.*name=/name=/' \
../package.xml >%{name}.xml
touch -r ../package.xml %{name}.xml
@@ -123,7 +119,6 @@ done | tee ../%{pear_name}.lang
%check
-src=$(pwd)/%{pear_name}-%{version}
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
# Retrieve version of Horde_Kolab_Format
@@ -135,10 +130,7 @@ sed -e "s/Horde_Kolab_Format_Xml-@version@/Horde_Kolab_Format_Xml-${VER}/" \
-i ComponentTest/Data/Object/Message/ModifiedTest.php \
ComponentTest/Data/Object/Message/NewTest.php
-phpunit \
- --include-path=$src/lib \
- -d date.timezone=UTC \
- .
+phpunit .
%clean
@@ -168,6 +160,11 @@ fi
%changelog
+* Fri Jan 09 2015 Remi Collet <remi@fedoraproject.org> - 2.1.2-1
+- Update to 2.1.2
+- add provides php-composer(horde/horde-kolab-storage)
+- raise dependency on Horde_Translation 2.2.0
+
* Tue Nov 25 2014 Remi Collet <remi@fedoraproject.org> - 2.1.1-2
- add suptream patch for test (thanks Koschei)