summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-08 11:41:18 +0100
committerRemi Collet <remi@remirepo.net>2021-03-08 11:41:18 +0100
commitabe5b8a957486bb314cb0095f4d310aa9a7295fb (patch)
tree1770edc476e2efbff832f1a9616ef7a0ddf594f8
parent36c6297014fd5744f9dcf6e7830ae1bcc3651d88 (diff)
imap extension is optionalHEADmaster
disable test suite with PHP 8
-rw-r--r--php-horde-Horde-Kolab-Storage.spec24
1 files changed, 15 insertions, 9 deletions
diff --git a/php-horde-Horde-Kolab-Storage.spec b/php-horde-Horde-Kolab-Storage.spec
index a3cf96b..ecb6548 100644
--- a/php-horde-Horde-Kolab-Storage.spec
+++ b/php-horde-Horde-Kolab-Storage.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-horde-Horde-Kolab-Storage
#
-# Copyright (c) 2013-2019 Remi Collet
+# Copyright (c) 2013-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -10,15 +10,17 @@
%global bootstrap 0
%global pear_name Horde_Kolab_Storage
%global pear_channel pear.horde.org
-%if %{bootstrap}
-%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+
+%if 0%{?fedora} >= 35
+# Old phpunit is not compatible with PHP 8
+%bcond_with tests
%else
-%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%bcond_without tests
%endif
Name: php-horde-Horde-Kolab-Storage
Version: 2.2.4
-Release: 1%{?dist}
+Release: 5%{?dist}
Summary: A package for handling Kolab data stored on an IMAP server
License: LGPLv2
@@ -30,7 +32,7 @@ BuildRequires: gettext
BuildRequires: php(language) >= 5.3.0
BuildRequires: php-pear(PEAR) >= 1.7.0
BuildRequires: php-channel(%{pear_channel})
-%if %{with_tests}
+%if %{with tests}
# To run unit tests
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-pear(%{pear_channel}/Horde_Test) >= 2.1.0 with php-pear(%{pear_channel}/Horde_Test) < 3)
@@ -56,7 +58,6 @@ Requires(post): %{__pear}
Requires(postun): %{__pear}
Requires: php(language) >= 5.3.0
Requires: php-date
-Requires: php-imap
Requires: php-json
Requires: php-pcre
Requires: php-spl
@@ -75,6 +76,7 @@ Recommends: (php-pear(%{pear_channel}/Horde_Imap_Client) >= 2.14.0 with php-
Recommends: (php-pear(%{pear_channel}/Horde_History) >= 2.0.0 with php-pear(%{pear_channel}/Horde_History) < 3)
Recommends: php-pear(HTTP_Request)
Recommends: php-pear(Net_IMAP) >= 1.1.0
+Recommends: php-imap
%else
Requires: php-pear(%{pear_channel}/Horde_Cache) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Cache) < 3.0.0
@@ -154,7 +156,7 @@ done | tee ../%{pear_name}.lang
%check
-%if %{with_tests}
+%if %{with tests}
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
# Retrieve version of Horde_Kolab_Format
@@ -168,7 +170,7 @@ sed -e "s/Horde_Kolab_Format_Xml-@version@/Horde_Kolab_Format_Xml-${VER}/" \
ret=0
if phpunit --atleast-version 4; then
- for cmd in php php56 php70 php71 php72 php73 php74; do
+ for cmd in php php73 php74; do
if which $cmd; then
$cmd %{_bindir}/phpunit --bootstrap bootstrap.php --verbose . || ret=1
fi
@@ -206,6 +208,10 @@ fi
%changelog
+* Mon Mar 8 2021 Remi Collet <remi@remirepo.net> - 2.2.4-5
+- imap extension is optional
+- disable test suite with PHP 8
+
* Mon Nov 4 2019 Remi Collet <remi@remirepo.net> - 2.2.4-1
- update to 2.2.4
- drop patch merged upstream