summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-JavascriptMinify.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-06-23 07:48:55 +0200
committerRemi Collet <remi@remirepo.net>2017-06-23 07:48:55 +0200
commit5bf1806b0f4f95c96f10faba465d2e360ec2324e (patch)
tree1a276f3f522ba427d0309f7e2f313549feec2f4d /php-horde-Horde-JavascriptMinify.spec
parent013ce1484714400a61f7397aa81830f2725c4ce8 (diff)
v1.1.4
Diffstat (limited to 'php-horde-Horde-JavascriptMinify.spec')
-rw-r--r--php-horde-Horde-JavascriptMinify.spec40
1 files changed, 34 insertions, 6 deletions
diff --git a/php-horde-Horde-JavascriptMinify.spec b/php-horde-Horde-JavascriptMinify.spec
index bfa56d9..cbf7d13 100644
--- a/php-horde-Horde-JavascriptMinify.spec
+++ b/php-horde-Horde-JavascriptMinify.spec
@@ -9,9 +9,10 @@
%{!?__pear: %global __pear %{_bindir}/pear}
%global pear_name Horde_JavascriptMinify
%global pear_channel pear.horde.org
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: php-horde-Horde-JavascriptMinify
-Version: 1.1.3
+Version: 1.1.4
Release: 1%{?dist}
Summary: Javascript Minification
@@ -20,11 +21,18 @@ License: LGPLv2
URL: http://pear.horde.org/
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php(language) >= 5.3.0
BuildRequires: php-pear(PEAR) >= 1.7.0
BuildRequires: php-channel(%{pear_channel})
+%if %{with_tests}
+# To run unit tests
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.2.7
+BuildRequires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Log) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
+%endif
+
Requires(post): %{__pear}
Requires(postun): %{__pear}
@@ -63,7 +71,6 @@ cd %{pear_name}-%{version}
%install
cd %{pear_name}-%{version}
-rm -rf %{buildroot}
%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
@@ -74,8 +81,25 @@ mkdir -p %{buildroot}%{pear_xmldir}
install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
-%clean
-rm -rf %{buildroot}
+%check
+%if %{with_tests}
+export LANG=fr_FR.utf8
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ if %{_bindir}/phpunit --atleast-version 4.8; then
+ $cmd %{_bindir}/phpunit --verbose .
+ else
+ : PHPUnit is too old for this package
+ fi
+ fi
+done
+exit $ret
+%else
+: bootstrap build with test suite disabled
+%endif
%post
@@ -90,14 +114,18 @@ fi
%files
-%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/JavascriptMinify/
%{pear_phpdir}/Horde/JavascriptMinify.php
+%doc %{pear_testdir}/%{pear_name}
%changelog
+* Fri Jun 23 2017 Remi Collet <remi@remirepo.net> - 1.1.4-1
+- Update to 1.1.4
+- enable test suite
+
* Wed Mar 09 2016 Remi Collet <remi@fedoraproject.org> - 1.1.3-1
- Update to 1.1.3