summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-02 18:50:29 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-02 18:50:29 +0100
commita4d47b28c0c74d1c41f2b90926e7efaefa855438 (patch)
tree1ee7f9f14e8781c16a06bb69b1b7a236cb475e4c
parent4e98c925fd6e28ac53640283cb90c606d1193d33 (diff)
php-horde-Horde-Injector: 2.0.0
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-Injector.spec62
2 files changed, 44 insertions, 22 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-Injector.spec b/php-horde-Horde-Injector.spec
index 991a92f..adc7301 100644
--- a/php-horde-Horde-Injector.spec
+++ b/php-horde-Horde-Injector.spec
@@ -1,39 +1,45 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
-%global pear_name Horde_Injector
+%global pear_name Horde_Injector
+%global pear_channel pear.horde.org
Name: php-horde-Horde-Injector
-Version: 1.0.1
+Version: 2.0.0
Release: 1%{?dist}
Summary: Horde dependency injection container
Group: Development/Libraries
License: BSD
URL: http://pear.horde.org
-Source0: http://pear.horde.org/get/%{pear_name}-%{version}.tgz
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
-BuildRequires: php-pear >= 1:1.4.9-1.2
+BuildRequires: php-pear
+BuildRequires: php-channel(%{pear_channel})
+# To run unit tests
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.0.0
+
Requires(post): %{__pear}
Requires(postun): %{__pear}
-Provides: php-pear(pear.horde.org/%{pear_name}) = %{version}
-Requires: php-pear(pear.horde.org/Horde_Exception) < 2.0.0
-Requires: php-pear(PEAR) >= 1.7.0
-BuildRequires: php-channel(pear.horde.org)
-Requires: php-channel(pear.horde.org)
+Requires: php(language) >= 5.3.0
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
%description
A dependency injection container for Horde.
-%prep
-%setup -q -c
-[ -f package2.xml ] || mv package.xml package2.xml
-mv package2.xml %{pear_name}-%{version}/%{name}.xml
-# Create a "localized" php.ini to avoid build warning
-cp /etc/php.ini .
-echo "date.timezone=UTC" >>php.ini
+%prep
+%setup -q -c -T
+tar xif %{SOURCE0}
cd %{pear_name}-%{version}
+cp ../package.xml %{name}.xml
%build
@@ -43,14 +49,20 @@ cd %{pear_name}-%{version}
%install
cd %{pear_name}-%{version}
-PHPRC=../php.ini %{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%check
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+phpunit AllTests.php
+
%post
%{__pear} install --nodeps --soft --force --register-only \
@@ -59,16 +71,22 @@ install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
%postun
if [ $1 -eq 0 ] ; then
%{__pear} uninstall --nodeps --ignore-errors --register-only \
- pear.horde.org/%{pear_name} >/dev/null || :
+ %{pear_channel}/%{pear_name} >/dev/null || :
fi
+
%files
+%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/Injector
%{pear_phpdir}/Horde/Injector.php
-%{pear_testdir}/Horde_Injector
+%{pear_testdir}/%{pear_name}
+
%changelog
+* Fri Nov 2 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.0-1
+- Update to 2.0.0 for remi repo
+
* Sat Jan 28 2012 Nick Bebout <nb@fedoraproject.org> - 1.0.1-1
- Initial package