summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-10-01 13:59:36 +0200
committerRemi Collet <remi@remirepo.net>2019-10-01 13:59:36 +0200
commiteccf99a44f6af4ea63520079d35a390bfddd017a (patch)
treed84b7bc0da585d4f25a46792aefb5368bb442823
parentbd6accf90836b99c2e013f98bb540a7c7dd64512 (diff)
- add patch for PHP 7.4 from
https://github.com/horde/Imap_Client/pull/9
-rw-r--r--9.patch22
-rw-r--r--php-horde-Horde-Imap-Client.spec13
2 files changed, 32 insertions, 3 deletions
diff --git a/9.patch b/9.patch
new file mode 100644
index 0000000..4ecf872
--- /dev/null
+++ b/9.patch
@@ -0,0 +1,22 @@
+From fac0813d75d9ab552985667eb4ed74f188679e65 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 1 Oct 2019 13:38:23 +0200
+Subject: [PATCH] Trying to access array offset on value of type null (7.4)
+
+---
+ lib/Horde/Imap/Client/Socket/ClientSort.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/Horde/Imap/Client/Socket/ClientSort.php b/lib/Horde/Imap/Client/Socket/ClientSort.php
+index 4030492a..a93853ab 100644
+--- a/lib/Horde/Imap/Client/Socket/ClientSort.php
++++ b/lib/Horde/Imap/Client/Socket/ClientSort.php
+@@ -110,7 +110,7 @@ public function clientSort($res, $opts)
+ }
+
+ $mbox = $this->_socket->currentMailbox();
+- $fetch_res = $this->_socket->fetch($mbox['mailbox'], $query, array(
++ $fetch_res = $this->_socket->fetch(isset($mbox['mailbox']) ? $mbox['mailbox'] : null, $query, array(
+ 'ids' => $res
+ ));
+
diff --git a/php-horde-Horde-Imap-Client.spec b/php-horde-Horde-Imap-Client.spec
index ecd6a8e..ed26051 100644
--- a/php-horde-Horde-Imap-Client.spec
+++ b/php-horde-Horde-Imap-Client.spec
@@ -13,13 +13,15 @@
Name: php-horde-Horde-Imap-Client
Version: 2.30.0
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Horde IMAP abstraction interface
License: LGPLv2
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+Patch0: https://patch-diff.githubusercontent.com/raw/horde/Imap_Client/pull/9.patch
+
BuildArch: noarch
BuildRequires: php(language) >= 5.3.0
BuildRequires: php-pear(PEAR) >= 1.7.0
@@ -122,11 +124,13 @@ drivers.
%prep
%setup -q -c
cd %{pear_name}-%{version}
+%patch0 -p1
# Don't install .po and .pot files
# Remove checksum for .mo, as we regenerate them
sed -e '/%{pear_name}\.po/d' \
-e '/%{pear_name}\.mo/s/md5sum=.*name=/name=/' \
+ -e '/ClientSort.php/s/md5sum=.*name=/name=/' \
../package.xml >%{name}.xml
touch -r ../package.xml %{name}.xml
@@ -166,8 +170,7 @@ export LANG=C.UTF-8
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
ret=0
-# TODO 7.4 Trying to access array offset on value of type null
-for cmd in php php71 php72 php73; do
+for cmd in php php71 php72 php73 php74; do
if which $cmd; then
if %{_bindir}/phpunit --atleast-version 4.8; then
$cmd %{_bindir}/phpunit --bootstrap bootstrap.php --verbose . || ret=1
@@ -206,6 +209,10 @@ fi
%changelog
+* Tue Oct 1 2019 Remi Collet <remi@remirepo.net> - 2.30.0-2
+- add patch for PHP 7.4 from
+ https://github.com/horde/Imap_Client/pull/9
+
* Mon Sep 30 2019 Remi Collet <remi@remirepo.net> - 2.30.0-1
- update to 2.30.0