summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-horde-Horde-Image.spec26
1 files changed, 20 insertions, 6 deletions
diff --git a/php-horde-Horde-Image.spec b/php-horde-Horde-Image.spec
index 950228f..e266934 100644
--- a/php-horde-Horde-Image.spec
+++ b/php-horde-Horde-Image.spec
@@ -1,12 +1,21 @@
-%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+# spec file for php-horde-Horde-Image
+#
+# Copyright (c) 2012-2014 Nick Bebout, Remi Collet
+#
+# License: MIT
+# https://fedoraproject.org/wiki/Licensing:MIT#Modern_Style_with_sublicense
+#
+# Please, preserve the changelog entries
+#
+%{!?__pear: %global __pear %{_bindir}/pear}
+
%global pear_name Horde_Image
%global pear_channel pear.horde.org
-
# No test: all are skipped.
-%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: php-horde-Horde-Image
-Version: 2.0.5
+Version: 2.0.6
Release: 1%{?dist}
Summary: Horde Image API
@@ -107,9 +116,10 @@ done | tee ../%{pear_name}.lang
%check
%if %{with_tests}
+src=$(pwd)/%{pear_name}-%{version}
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-phpunit\
- -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
+phpunit \
+ --include-path=$src/lib \
-d date.timezone=UTC \
.
%else
@@ -140,6 +150,10 @@ fi
%changelog
+* Fri Apr 04 2014 Remi Collet <remi@fedoraproject.org> - 2.0.6-1
+- Update to 2.0.6
+- enable test suite
+
* Mon Jul 15 2013 Remi Collet <remi@fedoraproject.org> - 2.0.5-1
- Update to 2.0.5